Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Urgent: Help required! getting a 404 error on the whole forum

edited December 2006 in Vanilla 1.0 Help
HI all, MY Forum was supposed to go live in one hour. But i did something that seems to have screwed it up. I Added the plugin: Page Manager 2.4.1 by SirNot, the read me document says If you are using mod_rewrite in your vanilla installation, add these lines to your .htaccess file: #Pages RewriteRule ^page/(.*)$ index.php?Page=$1 [QSA,L Ok so i created a ,htaccess file and put those lines in it.. and saved it on my root! and since then on i am getting this error. I even deleted the .htaccess but it does now help. Error Msg: Not Found The requested URL /search/ was not found on this server. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request. I can access the main forum page, but can't even login or click on any other link.. i just get the above error if i do so... Help would be appreciated... waiting!

Comments

  • Options
    Chances are your .htaccess is getting cached by your host. I know GoDaddy does this. Give it a bit of time, and it should return to normal. If you suspect the extension itself is at fault, you might remove it from conf/extensions.php Also, if those lines above are exactly what you pasted, you're missing the closing bracket around QSA,L...
  • Options
    edited December 2006
    It had the closing bracket too.. and deleted the extension back then itself... The thing is.. if my files get cached.. i see the cache folder in my root.,. but i dont now.. so really puzzled about it... was there a default .htaccess in the root? Maybe i have overwritten it or something?
  • Options
    Try putting those instructions back into the .htaccess file, and putting the extension back where it was. Wait a bit for the .htaccess instructions to propagate correctly. If it's not that, then it's likely something specific to that extension and I don't have it installed to help much more than that... Good luck... :)
  • Options
    ok will try that, thanks for your help! one last thing: how do i check if mod rewrite is enabled on my server?? thanks
  • Options
    Hey david, i fixed the error... i had over written the .htaccess created by the plugin: friendly url's! Forum is back online`:D
  • Options
    Ah, good to hear, sorry I had to leave and couldn't help... I wish extensions wouldn't force a new .htaccess on you, but rather make you manually add lines in the current one...
  • Options
    ..Thats what this extension requested he do.. :)
  • Options
    I know, I know!! The friendly Url's extension asked me to add the .htaccess file to the root... just added it the way it came! and when page manager had those lines for .htaccess i just created a new file.. having forgotten that there was one already in my root! And bam when i uploaded it.. the old one was over written... ah gotta pay more attention now on!
This discussion has been closed.