Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Anyway to post YouTube videos without using BBCode?

blizeHblizeH ✭✭
edited September 2007 in Vanilla 1.0 Help
^ :-)

They suddenly stopped working and I've never been able to embed them since :(


  • Maybe transmorgifier could do it? It would depend on if vanilla strips tags before or after transmorgifier does its magic.
  • HTML formatter allows youtube as well
  • blizeHblizeH ✭✭
    edited February 2007
    Hmm, not sure how I'd work it with transmorgifier :( Looks complicated :P

    Just tried using HTML formatter (I've been using it for ages actually, but an old version) and I've not had any luck, I tried adding the following code:

    <object width="425" height="350"><param name="movie" value=""></param><param name="wmode" value="transparent"></param> <embed src="" type="application/x-shockwave-flash" wmode="transparent" width="425" height="350"></embed></object>

    And it doesn't show up anything at all :(
  • If I recall correctly the html formatter strips the embed tag so you'll need to edit the plugin and remove the embed tag from the code.
  • Awesome, thanks, just went to check and found this bit of interesting code:

    function VideoLink($Matches) { $Type = strtolower(trim($Matches[2])); $ID = $Matches[3]; switch($Type) { case 'google' : return ('<embed style="width: 400px; height: 326px;" id="VideoPlayback" '. 'type="application/x-shockwave-flash" src="'.$ID.'"></embed>'); case 'youtube' : return ('<object width="425" height="350"><param name="movie" value="'.$ID.'"></param>'. '<embed src="'.$ID.'" type="application/x-shockwave-flash" width="425" height="350"></embed>'. '</object>'); default : return $Matches[0]; } }

    Any idea what to do with that?
  • <video type="google">docid</video> <video type="youtube">video id</video>
  • I see, cheers. Just tried doing that:

    <video type="youtube">GNLDLyeepVs</video>

    No luck :(

    Am kinda tempted just to allow the embed tag, but if I can get it working like this ^ that'd be good too I guess, and a lot more secure :-)
  • edited February 2007
    do u have a test account on ur forum that i can use to test it
  • it's an option you have to enable in the extension file definitions. but I wouldn't get too settled in if I were you; some holes were found in this version (1.9), and I think I've fixed them (with 2.0), but we can't be too sure ;-)
  • blizeHblizeH ✭✭
    edited February 2007
    Ahh I see, cheers! How do I enable it then? Or maybe more specifically where can I get v2.0 from? :-)

    Edit: Nm, just seen you've updated it, cheers!

    I've just set this: define('HTML_VIDEO_TAG', 1);

    But still no luck getting that above video code working :(
  • blizeHblizeH ✭✭
    edited February 2007
    Jesus, it's completely screwed up loads of formatting HTML on the site now! Eep.

    Edit: in fact, every single post formatted as HTML is b0rked :(

    Of all the times to clear my recycle bin! :D
  • shit, sorry about that; managed to leave it on 'testing' mode... try it now, should be fixed
  • Ah that's excellent, cheers for fixing it so quickly! :-)

    Still not having any luck posting YouTube videos though for some reason, can you confirm this is correct please?

    <video type="youtube">GNLDLyeepVs</video>
  • NickENickE New
    edited February 2007
    ok, how about now?
  • w00t! Works an absolute treat, thank you so much!
  • Final question (sorry!) - anyway to post MySpace movies?
  • done
  • blizeHblizeH ✭✭
    edited February 2007

    You're a bloody legend, was just about to have a go at it myself, glad I checked here first! Thanks!

    <video type="myspace">1853735795</video>
    Is this correct?
  • should be, yes
  • blizeHblizeH ✭✭
    edited February 2007
    Edit: Sorry, I was being dumb, forgot to switch the video enable back to '1'! :-) Thanks again <3
This discussion has been closed.