Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Page Manager breaks with intl characters (åäö)

edited February 2007 in Vanilla 1.0 Help
After some trouble shooting I've discovered that the Page Manager extension breaks when you enter a page name containing non-english characters like the Swedish åäö. The tab is added, but clicking it sends you to the discussions front page. What's more, you cannot delete the newly made tab! After pressing the cross for delete, you're simply not "allowed" to choose that page in order to delete it! (Try for yourselves to see what I mean). As it stands now, you need to manually delete CustomPages.php from the PageMng extension folder to reset things. I've tried using the HTML equivalents to åäö, i.e. ä etc, but it won't work. Perhaps some sort of hack to replace Ã¥ and ä with a, and ö with o, would be possible that still kept the åäö visible to the user? Any ideas? Its a fantastic extension, albeit English-speaking only!

Comments

  • Options
    Very frustrating for you. This shouldn't be too hard to fix Thomas, at least the HTML equivalents to those characters should be a workable option.

    I have a habit of using an HTML non-breaking space which translates into a diamond with a ? in it sometimes. Very weird.

    So it's over to the experts... pic

    Posted: Wednesday, 21 February 2007 at 8:14AM (AEDT)

  • Options
    In all honesty, it's less frustrating now that I realised what was going on! But then again, åäö are pretty useful in Swedish, I guess that's why we have them! btw: anyone try integrating page manager with something like FCKeditor? Would make Vanilla a true mini-cms ;-)
  • Options
    Hälsningar Thomas, hur är du i dag?

    Posted: Wednesday, 21 February 2007 at 8:56AM (AEDT)

  • Options
    Hej Wanderer, allt är bra! But something tells me you're not native ;-)
  • Options
    Glad to hear all is good, and you're not talking about my underwear!

    No, not a Swedish bone in my ancestry but a great translating OS X widget!

    Samtal till dig som är mer sistnämnd.

    Posted: Wednesday, 21 February 2007 at 9:03AM (AEDT)

  • Options
    Right! But that last sentence makes absolutely no sense!
  • Options
    It's supposed to be: talk to you later pic

    Posted: Wednesday, 21 February 2007 at 10:53AM (AEDT)

  • Options
    Well it came out more like something like "discussion to you who are more last-mentioned". o.O
  • Options
    Yes, that's what I meant! pic

    Posted: Wednesday, 21 February 2007 at 11:54AM (AEDT)

  • Options
    hahahahah Laughing out loud!!
This discussion has been closed.