Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Problem with special characters + drop-down menus

tbrtbr
edited February 2007 in Vanilla 1.0 Help
Hi, I've been working on a revision of the Swedish translation for Vanilla the last few days. Now that I'm done and testing it out, I run into some problems. The Swedish charaters ÅåÄäÖö work fine when I replace them with their HTML versions (&Aring; &aring; &Auml; &auml; &Ouml; &ouml;). However, it doesn't work correctly in the drop down menus. As an example, on the advanced search page, when I look in the "sort results by" menu for user account search, it says "Anv&auml;ndarnamn" instead of "Användarnamn" (User name). When I look in the source, I see <option value="" selected="selected">Anv&auml;ndarnamn</option> The & has been turned into &amp;! It appears that it automatically parses everything for the menus into HTML, which means that it's done twice since I already did that with a manual search and replace... hence, problem.

I suppose that what I need to do is to replace all instances of special characters that are going to appear in menus with the actual character, so it can be parsed into the proper charater code by Vanilla instead of me. Fair enough. The only question is: how do I find them...? Supposedly, they're spread all over the definitions.php file... and they generally have very generic content, so just because I find the right word, I can't be sure I'm editing in the right place... I also must make lists of every single menu in the system... and well, I'd very much like to keep my sanity... so I wonder if anyone's got any idea of how to do this in a slightly less frustrating way?

Thanks

- tbr

Comments

  • Options
    Actually, you should probably not use &xuml; in the translation anywhere, but instead the original characters, and save the file as UTF-8.
  • Options
    Yay! Thanks, it worked. :)
This discussion has been closed.