Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

SMTP Authentication Error

edited February 2007 in Vanilla 1.0 Help
Hello, I've just installed the latest version of Vanilla on my pretty clean Ubuntu Edgy box. Everything is working fine except for the email functions. Every time it's supposed to send an email it fails with the following error code: 503 5.5.1 Error: authentication not enabled I've been on the net trying to fix this (I'm using postfix) but it's pretty confusing. Is there anything very simple I can do to get email to work from this box? I don't need an ISP-quality email system. Really just the occasional email notification out. Thanks, Matt

Comments

  • Options
    I tried this on my edgy install and got some warnings that the time zone was not set properly. Not sure if it makes much difference but I'm running Ubuntu server.

    You could probably get around your error by setting the SMTP account options in Vanilla, so that your provider's mail server is used to send outgoing mail messages.
  • Options
    MarkMark Vanilla Staff
    I'd just try removing the smtp authentication altogether so that it just sends via php directly. 99% of the time people shouldn't need to specify the smtp information.
  • Options
    Ok, this sounds promising. How do I configure Vanilla to handle it in PHP and forget SMTP? Also forgot to add that I can use the 'mail' program at the shell with no problem. I'm a bit stumped here.
  • Options
    Ok, that got it. I just commented out the user and password lines in my settings.php and restarted apache. Thanks.
  • Options
    MarkMark Vanilla Staff
    Right on - glad you got it working...
  • Options
    One thing which just struck me which didnt occur to me yesterday is that if you change any settings those lines will become uncommented (will they, Mark? or is it selective?) and it will break again. Probably the best plan of action would just be to delete the user and password from the Application Settings screen (which will have the same effect). You also shouldnt need to restart apache :)
  • Options
    What did you end up having to do to get it to send a email to the admin when a new user is created?
Sign In or Register to comment.