Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Editing COOKIE_DOMAIN in conf/settings.php

edited May 2008 in Vanilla 1.0 Help
Is there some sort of trick to editing the cookie domain? I currently have mine set up to '' and would like to change it to '' but for some reason when I edit the conf/settings.php, the setting doesn't change the cookie being set. Am I missing something?


  • MarkMark Vanilla Staff
    After you change it, click on "Application Settings" again to reload the form. Scroll down and make sure that it saved properly.

    If it didn't, then you need to change your permissions on conf/settings.php so that it can be opened, edited, and saved by PHP.

    If it did take, then you need to erase your existing cookies before the new ones will take. You can do this through your browsers menus. Simply signing out won't work because now that you've changed the cookie domain, when vanilla tries to delete your cookies as you sign out, it references the NEW domain and doesn't find anything to delete.
  • Hmm, still no luck. I've tried your above instructions and cleared cookies in 3 different web browsers, and for some reason it still sets the cookie using "". Has anyone had issues with the cookie domain before? Thanks...
  • MarkMark Vanilla Staff
    You've verified that your settings.php file contains the correct value?
  • edited February 2007
    Mark, thank you for keeping up on this post. I think I figured it out. I did some searching and found an .htaccess parameter which forces the server to use the cross-subdomain cookies...

    // in .htaccess at the root of '' dir and any other subdomain's dir php_value session.cookie_domain ""

    Thanks again, looking forward to more vanilla goodness.
  • Argh, scratch that. It was working for a minute, the cookie was identified as ''... and now it's back to ''. Even though my .htaccess and conf/settings.php both tell it to use ''. I think my server hates me. If anyone knows anything else about this, I would appreciate a comment. Thanks.
  • MarkMark Vanilla Staff
    Are you using a windows server?
  • Nope, I am using a linux Media Temple gridserver...
  • Is the fact this code shows different data for cookie path the reason i cant get some HTML extensions to operate? // People Settings $Configuration['AUTHENTICATION_MODULE'] = 'People/People.Class.Authenticator.php'; $Configuration['SESSION_NAME'] = ''; $Configuration['COOKIE_USER_KEY'] = 'lussumocookieone'; $Configuration['COOKIE_VERIFICATION_KEY'] = 'lussumocookietwo'; $Configuration['SESSION_USER_IDENTIFIER'] = 'LussumoUserID'; $Configuration[''] = ''; $Configuration['COOKIE_PATH'] = '/'; $Configuration['SUPPORT_EMAIL'] = '[email protected]'; $Configuration['SUPPORT_NAME'] = 'Support'; $Configuration['LOG_ALL_IPS'] = '0'; $Configuration['FORWARD_VALIDATED_USER_URL'] = './'; $Configuration['ALLOW_IMMEDIATE_ACCESS'] = '0'; $Configuration['DEFAULT_ROLE'] = '0'; $Configuration['APPROVAL_ROLE'] = '3'; $Configuration['SAFE_REDIRECT'] = 'people.php?PageAction=SignOutNow'; $Configuration['PEOPLE_USE_EXTENSIONS'] = '1'; $Configuration['DEFAULT_EMAIL_VISIBLE'] = '0'; my current cookie domain is my domain name: my path is the subfolder my forum is set in /vanilla/
  • Please ignore above string. I updated the extension (dojo) with some mods that i found elsewhere the problem seems to be rooted in IE and the subsequent JS
  • IE and "rooted" in the same sentence yet again, I wish people would stop doing that, it's very embarrassing 'cos I wet my pants each time!
  • I can only hope to attain your wit and knowledge kind sir.
This discussion has been closed.