HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

Pulsing background colour of newly added comment.

edited March 2007 in Vanilla 1.0 Help
I feel like I'm going crazy. I thought I noticed that whenever I added a comment, the background pulsed a few times to indicate your new comment placement. I don't see this happening anywhere (on my site or this community) and I'm wondering if I am truly insane or (hopefully) there's some other explanation.

Comments

  • You're not insane... It's an extension called Yellow Fade.
  • Ah..thanks! It was driving me nuts, because I noticed the SmoothPageJump extension wasn't working as well, so I jumped to conclusion that something was a muck. Now, I just need to figure out why SmoothPageJump ain't working...
  • Actually, it appears Yellow Fade makes the SmoothPageJump not work. I only have 3 extensions installed: JQuery, SmoothPageJump and Yellow Fade. SmoothPageJump only works when I turn off Yellow Fade.
  • MarkMark Vanilla Staff
    I'd check them to see if there are naming conflicts in the js files. If that's the case, choose one of the files and change the function names and calls and it should work dandy.
  • Is there any trick to finding naming conflicts? I mean, there's a lot of js code between the two extensions.
  • Well, I found the problem, sorta. It has to do with the last function "DoFade" when in change the name the function itself, to say "DoFade_test", the SmoothPage extension works. However, since I haven't updated all calls to "DoFade_test" the Yellow Fade doesn't work. Simple, you say, just update all calls to "DoFade_test"...well when I replace all instances of "DoFade" with the test version, the SmoothPage stops working again. Ugh.
  • I discovered this months ago, I ditched Smooth Page Jump so Yellow Fade would work. pic

    Posted: Thursday, 1 March 2007 at 1:04PM (AEDT)

  • Smooth Page Jump only worked at the very beginning for me, but now I've so many extensions installed I don't know which one causes the conflict... And it's not Yellow Fade because I don't use it.
  • Actually, it appears Yellow Fade makes the SmoothPageJump not work. I only have 3 extensions installed: JQuery, SmoothPageJump and Yellow Fade. SmoothPageJump only works when I turn off Yellow Fade.

    Actually, there was an issue which made SmoothPageJump not work if you had JQuery. It should be fixed now though, see this discussion.
  • Aie, older versions of the JQuery extension broke SPJ, but it was fixed up with 1.1.0. Also, you just have t make sure that JQuery is enabled BEFORE SPJ, it's probably worth ensuring it's before Yellow Fade as well, but I've not tested with that yet.
  • edited March 2007
    Hmm.. I must be doing something wrong. I deleted all 3 extensions, downloaded the latest ones from here and uploaded to my server. Then I clicked JQuery, SmoothPageJump and YellowFade in that order. Yet, SmoothPageJump still ain't working. I double checked the extensions in the conf directory: include($Configuration['EXTENSIONS_PATH']."JQuery/default.php"); include($Configuration['EXTENSIONS_PATH']."SmoothPageJump/default.php"); include($Configuration['EXTENSIONS_PATH']."YellowFade/default.php"); Unchecking YellowFade is the only way to get SPJ working ...so I dunno...
  • Must be a conflict between yellow fade and SPJ. Have you tried it without JQuery enabled at all and with the other two enabled after each other in a different order?
  • Hmm...this is getting confusing, so this is what I did: - if I remove JQuery and reverse the order of Yellow Fade adn SPJ, then both work. - if I add JQuery back on so that the order is YF, SPJ, JQ - fade works, but SPJ only scrolls to Top, not bottom. - if the order is JQuery, YF, SPJ - then SPJ doesn't work.
This discussion has been closed.