Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Fresh install bug

dexdex
edited September 2007 in Vanilla 1.0 Help
As a test I installed vanilla 1.1 on my box (locally) everything went smoothly until I got to the part where the admin logs in. It processes the login and takes you to the discussions. But it doesn't login. No clue if this is a bug with installing it locally, though I don't think so because I've never had any problems with previous versions.

Comments

  • Options
    MarkMark Vanilla Staff
    Open up your conf/settings.php and take a look at your cookie and session settings - these ones:

    $Configuration['COOKIE_USER_KEY'] = 'lussumocookieone'; $Configuration['COOKIE_VERIFICATION_KEY'] = 'lussumocookietwo'; $Configuration['SESSION_USER_IDENTIFIER'] = 'LussumoUserID'; $Configuration['COOKIE_DOMAIN'] = '.domain.com'; $Configuration['COOKIE_PATH'] = '/';

    Then also make sure to wipe out your old forum cookies and kill any active sessions before trying to sign in.
  • Options
    edited March 2007
    I have this same problem on a fresh Ubuntu Dapper box with php4/apache2. I don't have the $Configuration['COOKIE_USER_KEY'] = 'lussumocookieone'; $Configuration['COOKIE_VERIFICATION_KEY'] = 'lussumocookietwo'; $Configuration['SESSION_USER_IDENTIFIER'] = 'LussumoUserID'; Configurations but my COOKIE_DOMAIN and COOKIE_PATH are accurate.
  • Options

    test
  • Options
    MarkMark Vanilla Staff
    You don't necessarily need those three settings - the defaults (as you see above) should be just fine.

    I guess the next step is to see if any session or cookie values are actually being set when you sign in. Try signing in and then look in your browser's options to see what the cookie values are for your domain (php stores it's session info in cookies).
  • Options
    Session gets written on the server side in /var/lib/php4 however, my browser shows no cookies for my domain after clearing cache/cookies and relogging into Vanilla.
  • Options
    pbearpbear New
    edited March 2007
    Same thing here on a localized MAMP setup with a fresh Vanilla 1.1 install.

    I'm also missing these three:
    $Configuration['COOKIE_USER_KEY'] = 'lussumocookieone'; $Configuration['COOKIE_VERIFICATION_KEY'] = 'lussumocookietwo'; $Configuration['SESSION_USER_IDENTIFIER'] = 'LussumoUserID';

    Edit:I'm not seeing any new cookies, after clearing them. I applied as if a new applicant though, then tried to relog as the admin. I get the "review new membership applicants" intro, but clicking that gives me the same logged out result as before.
  • Options
    pbearpbear New
    edited March 2007
    Ok, since I had to put the computer to sleep on and off during the day, maybe that messed something up. Tried a reboot to clear things out. I still can't get the login.

    Edit: On a positive note, other upgraded installations are working without a hitch, with a load of extensions to boot.
  • Options
    I had the same issue. The problem comes from the cookie domain.

    I created a virtual host for my vanilla installations, and left localhost for XAMPP.
    My forum was http://eclipse/vanilla and $Configuration['COOKIE_DOMAIN'] was set to 'eclipse'. I could find any cookies for vanilla.
    I guessed one word is not a valid cookie domain name.

    I set the virtual host and $Configuration['COOKIE_DOMAIN'] to '.eclipse.localhost' (and set it also in C:\WINDOWS\system32\drivers\etc\hosts), and it was working again. There might be better fix, like set $Configuration['COOKIE_DOMAIN'] to an empty string or to '.localhost'. I should have tried.
  • Options
    It currently says:
    $Configuration['COOKIE_DOMAIN'] = 'localhost:8888'; $Configuration['COOKIE_PATH'] = '/forum/';
    http://localhost:8888/forum/ gets me to the message board all right.

    Setting COOKIE_DOMAIN to ' ' (blank, but with no space) doesn't fix it.

    There's also this a bit earlier in the conf/settings.php:
    $Configuration['WEB_ROOT'] = '/forum/'; $Configuration['BASE_URL'] = 'http://localhost:8888/forum/'; $Configuration['FORWARD_VALIDATED_USER_URL'] = 'http://localhost:8888/forum/';
  • Options
    MarkMark Vanilla Staff
    I've got my local dev version of Vanilla running at localhost:8010. I had similar problems with my cookie domain and I fixed them by using these settings:

    $Configuration['COOKIE_DOMAIN'] = ''; $Configuration['COOKIE_PATH'] = '/';

    Of course, I had to go through the usual hoops of signing out, removing all cookie and session variables, closing and restarting firefox. But it worked dandy after that.
  • Options
    Well, there you go. That new COOKIE_PATH did it.

    Thanks Mark and Dinoboff for the assist!

    I seem to remember "/forum/" was auto-suggested in the installation. Hrmm...
  • Options
    That just fixed my local install, too. Thanks.
  • Options
    I believe that i have the same problem, but I don't follow what you all are saying. Could someone tell me what I need to do in order to log into my newly installed forums?
  • Options
    I have also tried to change $Configuration['COOKIE_DOMAIN'] = 'www.imahussey.com'; to Configuration['COOKIE_DOMAIN'] = ''; but no dice. Unless I need to restart something or do something else.
  • Options
    edited September 2007
    See your original discusion: http://lussumo.com/community/?CommentID=76022
This discussion has been closed.