Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

'Edit' doesn't work anymore (solved)

TexTex
edited November 2007 in Vanilla 1.0 Help
I changed the title of this discussion. Since some days, editing a comment dosen't work any more. When clicking edit, it starts a new discussion. Am I the only one with this problem? I am running Vanilla 1.1.2.

According to my host, I had to remove 'Options +FollowSymLinks -Multiviews' from my .htaccess as it delivered a 500 Error. I tested it with another forum, and the problem could not be reconstructed.

My question is, where this edit problem may come from and if I am the only one having it.

Comments

  • Options
    TexTex
    edited March 2007
    Found a similar thread: http://lussumo.com/community/?CommentID=61824 (Weird Edit Problem # 19)
  • Options
    Try to upload Vanilla again.
    Do have use friendly Url?
  • Options
    Thanks Dinoboff.
    I uploaded everything again except the styles and languages. Still doesn't work.
    I use Friendly Urls, yes. Editing works unless I activate them.
  • Options
    It is working with friendly url off but not when it is on?

    Do you have access to you logs? access_log and rewrite log?
  • Options
    TexTex
    edited March 2007
    It is working with friendly url off but not when it is on?
    Right. I guess my host has upgraded his php or mysql version, if this might be the problem. There seems like there has been a problem with an old vanilla version as mentioned in the above linked discussion.

    I do have access to access_log, but I can't find a rewrite log.
  • Options
    I will have to check what info are the access_log that could help.
  • Options
    I just discover another problem. No matter which account id is given, it ends up at the own account. Guest get redirected to /discussions/.
    For example: /account/84/
    -> the browser Url field says /account/84/ but the location actually is /account/ (if logged in) or /discussions/ (for guests)
  • Options
    edited March 2007
    I just tried the .htaccess you sent me and I can't reproduce the error. I think you need the rewrite log to fix it. You will need the help of the host.
  • Options
    Never mind, I could :-D

    You have to ask your host to turn off Multiviews on the vanilla folders
  • Options
    I asked my host and we'll see what he can do. Thank you for all your time!
  • Options
    It worked out! Thanks again.
  • Options
    A thank you: I just had the same problem after transferring a site from a local install online - clicking on edit brings up a new discussion form and not the edit panel. Eventually I found this thread as well as Dinoboffs Friendly URL thread. Removing the # that commented out the following line at the top of the .htaccess solved it for me.

    Options +FollowSymLinks -Multiviews
  • Options
    Why was it comment out? You should only comment it out if you host doesn't allow you to use the 'Option' directive.
This discussion has been closed.