Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Error in 1.1.2

ThaRiddlaThaRiddla New
edited March 2007 in Vanilla 1.0 Help
I thought this followed from a separate thread, but I realized that it was my theme. I was using NamedVanilla and it produces the following error after the 1.1.2 install. Fatal error: Call to a member function on a non-object in /home/cafeint/public_html/library/Vanilla/Vanilla.Functions.php on line 18

Comments

  • Options
    Now that i've cleared my cache, i'm experiencing a larger problem. I am unable to login to the new install. I have followed the upgrade instructions in the documentation to no avail. I was upgrading from 1.0.3 any thoughts on how to solve this besides reinstalling 1.0.3? I am able to load the login page fine, but after entering my user/pass, it simply reloads the login page.
  • Options
    Most likely to be problem with cookie domain see this discussion: http://lussumo.com/community/discussion/5700/fresh-install-bug/#Comment_60943
  • Options
    MarkMark Vanilla Staff
    And I bet your original problem is related to this:

    1.1.1 Upgrade problem # 9
  • Options
    RE:1.1.1 upgrade problem #9
    I have changed that code in the NamedVanilla/discussions.php file

    RE: Fresh Install Bug, cookie domain..I don't have the following in my conf/settings.php file:
    $Configuration['COOKIE_USER_KEY'] = 'lussumocookieone'; $Configuration['COOKIE_VERIFICATION_KEY'] = 'lussumocookietwo'; $Configuration['SESSION_USER_IDENTIFIER'] = 'LussumoUserID';
    Should I add them as-is?

    For Clarification, I am able to access people.php for the login prompt. It looks to load successfully but does not take me to discussions, it reloads with the login screen again.
  • Options
    MarkMark Vanilla Staff
    No - you don't need to add those three settings. They are the defaults and are applied already. Is your forum online? Can we test it?
  • Options
    edited March 2007
    You know, I think I can duplicate this issue. Vanilla 1.1.2 on my localhost, sign in and get directed to the discussion list which says 'not signed in'. Repeat, and get the same. Drop back to Vanilla 1.0.3, (which has the same cookie and database settings as 1.1.2) sign in, and now go back to 1.1.2 and I am now logged in. I can log in and out no problem. Even if I log out of 1.0.3 before going to 1.1.2 I can sign in. To again reproduce the error, I need to Tools->Clear Private Data in FF, including cookies, and suddenly I can't log in to 1.1.2 anymore. PHP 5.1.6 MySql 5.0.24a Cookie domain: 'wallphone' (an alias to 127.0.0.1 in my hosts file) cookie path: '/vanilla-1.1.2/'
  • Options
    Cookies can't be created (or can't be sent to vanilla) because there is a problem with the cookie domain; localhost is not a valid cookie domain.
  • Options
    Mark,

    I've added those three lines to my settings.php file. cleared my cache/all cookies and restarted my browser. same problem. I asked one of my other forum members (who hadn't visited in a while) to login and they are also unable.

    My forum is online, but it's closed registration

    http://cafe.intelligentsiacoffee.com
  • Options
    edited March 2007
    Dinoboff: I see, then my issue is probably more like this one: Fresh install bug # 11...

    Odd that this setup works in 1.0.3 but not in 1.1.2.

    ThaRiddla: I am curious what would happen if you replace the updated people files with the older versions... (Authenticator and UserManager) http://lussumo.com/docs/doku.php?id=vanilla:upgrading
  • Options
    WallPhone,

    I did successfully downgrade back to 1.0.3 with no issues. I just reversed my install procedure and i was able to access my forum.
  • Options
    Changing my cookie_path and cookie_domain to the ones listed above in problem #11 allows me to login and am greeted with the following error on the discussions.php page.

    Fatal error: Call to a member function on a non-object in /home/cafeint/public_html/library/Vanilla/Vanilla.Functions.php on line 18
  • Options
    Are you using an other theme than the default one?
  • Options
    @ wallPhone: since 1.1, vanilla assigned the cookie_domain and cookie_path settings to the session cookies as well as standard cookies.
  • Options
    ThaRiddlaThaRiddla New
    edited March 2007
    @ Dinfboff

    Excellent, I missed that when I resaved my settings file.

    I think it's all working now...just a problem with NamedVanilla Extension
  • Options
    MarkMark Vanilla Staff
    edited March 2007
    Odd that this setup works in 1.0.3 but not in 1.1.2.

    No. It's not. I understand why it is happening now.

    If you read nothing else in this discussion, read this: single-word domains are not relevant as a cookie domian. "Localhost", "something", "anything" will NOT work. You must use a domain name like ".lussumo.com" or "www.lussumo.com". If you are using an alias to an IP address, just leave the cookie_domain blank.

    If your cookies didn't work in previous versions and the sessions don't work after the upgrade to 1.1.2 it is because as of 1.1.2 Vanilla applies the same cookie_domain to sessions as it does to cookies. If your cookie domain is invalid, sessions will not work.
This discussion has been closed.