Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

There was a problem authenticating your post information.

edited June 2007 in Vanilla 1.0 Help
Hi, Just downloaded the latest release of Vanilla (1.1.2). This is a virgin install, as opposed to an update. Installation went swimmingly well, and as a W3C-standards Nazi, I'm really impressed. However, I have an error that pops up each time I try to install an extension. "There was a problem authenticating your post information" I've read other posts here that show similar issues, but I've checked browser cache, and even swapped between browsers, IE6 and 7, Opera 9.x and Firefox 2. to no avail. Two two extensions I've tried are: Applicant Email Verification Delete User I've checked the CHMOD permissions for the relevant directories, as per instructed in the FAQ, and they all seem in order. Any help would be greatly appreciated. I feel like the kiddie who's found the goodie jar but some swine has screwed the lid down too tightly! :) As an aside, there also seems to be an error with the Check for Updates page: Notice: Undefined property: UpdateCheck::$LussumoMessage in /home/{edited}/public_html/comm/themes/settings_update_check_validpostback.php on line 8 after clicking the "Check for Updates" button.
«1

Comments

  • Options
    MarkMark Vanilla Staff
    This is your post information problem:

    Problem after Updating 1.1.1 # 8
  • Options
    I actually managed to get this error on this forum once...
  • Options
    Thanks, Mark. I can confirm that PHP Sessions appear to be working perfectly however. I even did the visit count test as described in the thread you pointed me to. I'm a PHP developer and use PHP Sessions all day for various different projects on the same server. Any further thoughts?
  • Options
    MarkMark Vanilla Staff
    edited March 2007
    MazY - I honestly don't know how you could get that message if your sessions are working properly. I also don't understand how you could get that LussumoMessage error since the 1.1.2 release of Vanilla doesn't contain the LussumoMessage variable anymore: http://lussumo.com/svn/vanilla/tags/Vanilla-1.1.2/themes/settings_update_check_validpostback.php
  • Options
    MarkMark Vanilla Staff
    edited March 2007
    Is it possible you are using a outdated set of theme files?
  • Options
    Hmm All I can say is that I downloaded from here and installed normally. I'll get a friend to install to his server now. If i works for him then I know I'm at fault for sure! :) Thanks for the help.
  • Options
    MarkMark Vanilla Staff
    Get him to download it fresh :)
  • Options
    MarkMark Vanilla Staff
    I just downloaded from getvanilla.com and verified that the LussumoMessage variable doesn't appear in that theme file...
  • Options
    MarkMark Vanilla Staff
    I actually managed to get this error on this forum once...

    It can happen if you sign in with one browser, open a discussion in another window. Then sign out and back in. Then go back to your open discussion window and add a comment. You get the error because your session key has changed since the page was loaded. If you just click save again, it will post as it should.
  • Options
    Yeah I think I Was doing something crazy like going "Back", then changing my mind, clicking on a link and then another one - or something....
  • Options
    Sorry, guys. My fault completely. I had looked at another theme, or another version of the default theme and... Anyway, I just removed the entire theme directory, uploaded from the proper install zip and all seems fine now. Sorry to have wasted your time. Now I can dip my hands into the goodie jar!
  • Options
    MarkMark Vanilla Staff
    Hehehe - enjoy!
  • Options
    edited March 2007
    FWIW, I get the same error both when I try to check for updates AND when trying to enable an extension. "There was a problem authenticating your post information." When I test the visit count, as described, it does NOT increase. I tried clearing the cache and the cookies and restarting Firefox. I removed the theme directory and replaced it with the downloaded one...although that shouldn't have made a difference since I had already replaced it when I updated. (I replaced everything except the conf and extensions folders.) I've only been using Firefox, no other browsers running. I'm trying a fresh install in a test area, but I will need to upgrade on my real message board, which is 1.0.3. Is there something fancy about updating from 1.0.3 to 1.1.2? Directions to do that are NOT on the updates page, so I just followed the "Upgrading from Vanilla ... 1.0.3 to ... 1.1.1" directions. I don't understand the cookie_path configuration mentioned elsewhere. Mark says to "look at" these cookie and sessions settings: $Configuration['COOKIE_USER_KEY'] = 'lussumocookieone'; $Configuration['COOKIE_VERIFICATION_KEY'] = 'lussumocookietwo'; $Configuration['SESSION_USER_IDENTIFIER'] = 'LussumoUserID'; $Configuration['COOKIE_DOMAIN'] = '.domain.com'; $Configuration['COOKIE_PATH'] = '/'; Does that mean I should add the ones he listed, if I don't have them? If so, where?
  • Options
    the cookie thing is only if you can't log in. That's not your problem.

    Do you use the default language and the default theme (and without custom changes in /themes/vanilla/)?
  • Options
    I've had this error appear on *this* forum several times in the past week.

    I think in all cases I was interrupted whilst preparing a reply (that I *had* previewed) and
    then continued to edit. No logging in/out, and no back-buttons were used (harmed) in
    the process...
  • Options
    Yes, default language and default theme. No changes in the theme, I had just overwritten the themes folder with the one from the download.
  • Options
    Weird. I was able to update my REGULAR forum (the one with all the posts, the extensions, and other hoo haw) without any problem.) It was my empty one that crapped out on me.
  • Options
    @TomTester:

    The "There was a problem authenticating your post information" is a feature, not a bug. It is have been added to prevent CSRF attack
    It could be replaced by something more user friendly than an error message, a page that ask you to confirm your post for example.
  • Options
    Ah, ok, I just copy/pasted the content and hit "Add your comments" again. I think the error
    message indeed needs to be clarified (e.g. with the suggestion to submit your comment
    again)
  • Options
    Thing is, I wasn't adding a comment when it happened. I was checking for updates and enabling add-ons.
This discussion has been closed.