Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

turkish chars not displaying

edited March 2007 in Vanilla 1.0 Help
the turkish chars are not displaying correctly. it shows "?" char for this chars.


  • On which board?
    Is it utf-8?
    Test it here please.
  • they are working well in here for example "ÅžiĞüIı" but in my forum they are not working
  • Be sure your forum is correctly setup to use utf-8 charset.
    See this page for more details.
  • i added this $Configuration['DATABASE_CHARACTER_ENCODING'] = 'utf8'; line like it said but nothing changes :( please help
  • edited March 2007
    Have you check your server use mysql 4.1 or higher and that your vanilla table are utf8 encoded?

    I understand that the vanilla php files, the DB and the connection with the DB need to use utf8 encoding. And at the end, apache need to serve it as an utf8 encoded document. Do you know what are the effect of the AddDefaultCharset and AddCharset apache directive on this last part? Does the php header function overwrite it?
  • edited March 2007
    they are "latin1_swedish_ci" what must i do now?i am going to clean install vanilla again. please someone tell me the steps for the utf 8 encode part, thanks
  • i have installed the vanilla again clean. after the install i have made the changes to the conf/settings.php i have added $Configuration['DATABASE_CHARACTER_ENCODING'] = 'utf8'; this line but it still doesnt show the turkish chars. what i am doing wrong??
  • edited March 2007
    From Max_B's Characters encodings, the UTF-8 conundrum
    case # Vanilla charset connection charset database charset database state comment
    3 utf8 utf8 latin1 OK Limited to western languages, upgrade on MySQL side
    You need to set you database to utf8. The easiest way to do if the db is empty is to drop it and create with utf8 as default encoding.
  • can you describe more to do this? i dont understand what you mean with "drop it and create with utf8 as default encoding" :/
  • edited March 2007
    If you use phpMyAdmin, from the home page, go to database, then go in the vanilla batabase. Then clic on drop.
    Then, from phpMyAdmin home page, create a new database for vanilla selecting a utf8 collation.
    The result should be something like that:CREATE DATABASE `Vanilla` DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci;
    Now reinstall vanilla.
  • how can i set permission for creating database ? because it said me " MySQL said: Documentation #1044 - Access denied for user 'doknet'@'localhost' to database 'vanilla'"
  • ok i fixed it now. should i also add this $Configuration['DATABASE_CHARACTER_ENCODING'] = 'utf8'; line to the conf/settings.php ?
  • @Dinoboff: AddDefaultCharset is off by default and Apache manual clearly state that it is only relevant if there is no content/encoding header. I never tested this, but presumably setting it to utf-8 can save the concern of issuing encoding header for each served file. AddCharset is not found in my Apache manual.
This discussion has been closed.