Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Changing default Format comments as setting

raykrayk New
edited October 2007 in Vanilla 1.0 Help
Hey guys, I've upgraded to 1.1.2 of Vanilla - now I have BBInsertBar and BBCodeParser installed and running. So wondering how to set the comment section to have the default as BB code and not Text. It's the little thing "Format comments as (*) Text ( ) Html" , just instead of Html I have BBcode. Thanks for the help in advance.

Comments

  • Options
    There's a line in ForcedBBCode that can be added to BBCodeParser to make BBCode the default formatter. I don't have it to hand right now and must go to bed, but I think the ForcedBBCode default.php file is pretty well commented. I really should add that option to BBCodeParser so all people have to do is turn it on and off... If you can't figure it out I should have some time to find it tomorrow. Night night ;)
  • Options
    The code in ForcedBBCode is not perfect. This one is better:if ( $Context->Session->UserID > 0 && $Context->Session->User->Permission('PERMISSION_HTML_ALLOWED') ) { //Make BBCode formater the only formatter available to post a new comment or to edit an old one $Context->Configuration['DEFAULT_FORMAT_TYPE'] = 'BBCode'; $Context->Session->User->DefaultFormatType = 'BBCode'; $Context->Session->User->Preferences['ShowFormatSelector'] = 0; }
  • Options
    @Dinoboff - Where would I add that to?
  • Options
    StashStash
    edited March 2007
    If you can be patient I will add this option to BBCodeParser, thanks Dinoboff :)
  • Options
    Ah, awesome to hear Stash! Looking forward to it :).
  • Options
    OK, this is now in BBCodeParser 1.0.3 (currently not released). I'm hoping to be able to fix a URL Encode issue before releasing, but if I can't I'll release this, with a couple of other fixes in a day or two.
  • Options
    What is the issue?
  • Options
    A URL made up from both "normal" and URL encoded URLs is the problem. The version of the BBCodeParser that I'm using chokes on the URLEncoded part. I converted that part back to normal and it displayed just fine. An example can be seen on my test forum. Unfortunately, the List.php filter for BBCodeParser is (for me) bloody complicated.

    Example problem URL:[url=http://www.amazon.co.uk/gp/redirect.html?ie=UTF8&location=http%3A%2F%2Fwww.amazon.co.uk%2FDisney-Classics-Animals%2Fdp%2FB000DN5UV8%3Fie%3DUTF8%26s%3Ddvd%26qid%3D1173748176%26sr%3D1-4&tag=moma-21&linkCode=ur2&camp=1634&creative=6738]Amazon[/url]
  • Options
    We need SoftWrap here! pic

    Posted: Friday, 23 March 2007 at 7:44AM (AEDT)

  • Options
    can bbcode do classes
    if u want to add a class to an image is bbcode able to do that
  • Options
    with BBCodeParser & Better BBCode when I'm logged In with the admin account the default Format comments as Is BBCode but when logged In as a regular account the default Format comments as Is Text !! @Dinoboff - Where would we add that code to make BBCode the default ?!
  • Options
    lechlech Chicagoland
    Wouldn't those two extensions wage war with one another?
  • Options
    edited June 2007
    lech: when I use one of them I disable the other ... the point Is that I get the same Issue with both extensions...
  • Options
    lechlech Chicagoland
    Ahh, alright. Nevermind then.
  • Options
    @Rayk: did you try DefaultFormatter?

    @others: because DefaultFormatter can hide the selector for everyone upon admin request, I'd like DefaultFormatter to be able to hide the option "Show the comment format type selector when adding comments" in the account>forum preferences, somebody knows how to do that ?
  • Options
    well theres always:
    #AccountPage #ShowFormatSelector { display:none; }
    but that doesnt get rid of the words

    Comment form

This discussion has been closed.