Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

New Vanilla Install....how do I get the base URL I want?

edited March 2007 in Vanilla 1.0 Help
Hi there, I'd like to install a vanilla forum to this domain www.methodsreporter.com/talk/ However methodsreporter.com is an add-on domain, using a subdomain (my nomenclature is off but I think you get the idea). methodsreporter.com is actually methodsreporter.passinreviewonline.com So when I install vanilla, all the links in the forum look like this: methodsreporter.passinreviewonline.com/talk/post...... etc etc etc What do I edit to get rid of that passinreviewonline nonsense? I tried changing the conf/settings.php but that didn't do anything. I tried some mod_rewrite stuff but that's not fixing the links. I'm guessing I need to uninstall Vanilla. Edit some of the installation files. And then reinstall it. I'm guessing the longer domain was "hard written" during installation. Is this correct? if so what do I edit to get the URL I want? Is there another approach? Do i edit something in my database tables? THanks. Vanilla looks spectacular. I just hope I can get the URL's right with it.

Comments

  • Options
    I did exactly what I suspected would work....and eventually it did. 1. I deleted the conf folder and deleted all the tables. 2. In the installer.php file I typed in exactly the base URL I wanted. 3. I re-installed vanilla...and now its using the right URL and all the links function correctly.
  • Options
    You should have a web path to vanilla setting on your application settings screen...just change that. You might find it does funky stuff with regards to cookies though.
This discussion has been closed.