Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

A fatal, non-recoverable error during upgrade

edited April 2007 in Vanilla 1.0 Help
Hi, I received the following error message after upgrading from 1.0.3 to 1.1.2 when going going to /settings/

A fatal, non-recoverable error has occurred

Technical information (for support personel):

Error Message
The "ApplicantsForm" control referenced by "ApplicantsForm" does not appear to exist.
Affected Elements
ObjectFactory.CreateControl();

For additional support documentation, visit the Lussumo Documentation website at: lussumo.com/docs


I attempted several installations and they all resulted in the same error. Any solution to this problem?
Using PHP 4.3.11, FreeBSD 6.1

Comments

  • Options
    Would seem to me that your library folder didnt upload completely..
  • Options
    I unzipped the distribution archive straight from the shell, so if something was wrong in the library folder the problem may be present in the distribution as well.

    Any insight? How does this error occur?
  • Options
    MarkMark Vanilla Staff
    Problems can happen with your uploader - not the package. Thousands of other people have installed it without problems. I'd say try re-uploading.
  • Options
    It's most likely not due to an upload problem but due to a directory mixup - I just stumbled over the very same mistake and it took me some time to fugure out what was going on. I originally installed the old version in a subdirectory external/vanilla.1.0.3 and used a symlink vanilla->../../somepath/external/vanilla.1.0.3 to link to that directory. During the upgrade, I first cp'ed external/vanilla.1.0.3 to external/vanilla.1.1.2, then changed the symlink to point to this new directory instead and finally uploaded the new files, overwriting the relevant bits in this directory, just as suggested. And I ended up with this error. So I dug a little and edited ./library/Framework/Framework.Class.ObjectFactory.php so it would actually give me the name of the file it could not find when it ran into this error. I saved my change, called the page again - and the error message was still the same. It was only then that I figured that although the sidebar said that I am on the new version now, certain files must still reference the old installation. This actually wasn't too hard to find: The old path was being referenced in conf/settings.php! So I simply edited that and replaced any reference to the real path with the symlinked route for $Configuration['APPLICATION_PATH'], $Configuration['DATABASE_PATH'], $Configuration['LIBRARY_PATH'], $Configuration['EXTENSIONS_PATH'], $Configuration['LANGUAGES_PATH'] and $Configuration['THEME_PATH']. I hope this may help some people who ran into the same trap :) Kind regards Markus
  • Options
    MarkMark Vanilla Staff
    Thanks for your insight, Markus :)
This discussion has been closed.