Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

error on creating a blank discussion

edited March 2007 in Vanilla 1.0 Help
this is very weird. there is no comment text control in vanilla i think. i started a discussion in my forum and try to not write any comment only the subject and it gived me that error; Notice: Trying to get property of non-object in /home/hebele/public_html/hebel/library/Vanilla/Vanilla.Control.CommentGrid.php on line 71 Notice: Trying to get property of non-object in /home/hebele/public_html/hebel/library/Vanilla/Vanilla.Control.CommentGrid.php on line 71 Notice: Trying to get property of non-object in /home/hebele/public_html/hebel/library/Vanilla/Vanilla.Control.CommentGrid.php on line 86 Notice: Trying to get property of non-object in /home/hebele/public_html/hebel/library/Vanilla/Vanilla.Control.CommentGrid.php on line 86 Notice: Trying to get property of non-object in /home/hebele/public_html/hebel/comments.php on line 43 Notice: Trying to get property of non-object in /home/hebele/public_html/hebel/comments.php on line 51 Notice: Trying to get property of non-object in /home/hebele/public_html/hebel/comments.php on line 56 Notice: Trying to get property of non-object in /home/hebele/public_html/hebel/comments.php on line 56 Notice: Trying to get property of non-object in /home/hebele/public_html/hebel/comments.php on line 59 Notice: Trying to get property of non-object in /home/hebele/public_html/hebel/comments.php on line 64 Notice: Trying to get property of non-object in /home/hebele/public_html/hebel/comments.php on line 64 Notice: Trying to get property of non-object in /home/hebele/public_html/hebel/comments.php on line 64 Notice: Trying to get property of non-object in /home/hebele/public_html/hebel/comments.php on line 67 Notice: Trying to get property of non-object in /home/hebele/public_html/hebel/comments.php on line 72 Notice: Trying to get property of non-object in /home/hebele/public_html/hebel/comments.php on line 72 Notice: Trying to get property of non-object in /home/hebele/public_html/hebel/comments.php on line 72 Notice: Trying to get property of non-object in /home/hebele/public_html/hebel/comments.php on line 75 Notice: Trying to get property of non-object in /home/hebele/public_html/hebel/comments.php on line 80 Notice: Trying to get property of non-object in /home/hebele/public_html/hebel/comments.php on line 80 Notice: Trying to get property of non-object in /home/hebele/public_html/hebel/comments.php on line 80 Notice: Trying to get property of non-object in /home/hebele/public_html/hebel/comments.php on line 83 Notice: Trying to get property of non-object in /home/hebele/public_html/hebel/comments.php on line 88 Notice: Trying to get property of non-object in /home/hebele/public_html/hebel/comments.php on line 88 Notice: Trying to get property of non-object in /home/hebele/public_html/hebel/comments.php on line 88

Comments

  • Options
    I get the same result when you have a role with permission to delete discussions, but no permissions to view deleted discussions. Because deleting a discussion refreshes the same page, it will result in a error. I think when the system can't load the discussion it should redirect to the discussion index page.

    In your case, you create a new discussion which works (because it only needs the title), but as it cannot create a comment (due to empty commentbox) it results in the described behaviour. I think this is a bug which exists for quite some time now :)
  • Options
    but i am an admin and i have all these permissions :/
  • Options
    MarkMark Vanilla Staff
    *Bookmarked*
  • Options
    @ abramelin see: http://lussumo.com/community/discussion/5661/attachments-21-and-empty-discussion-submission/ Out of the box Vanilla does have 'no comment text control', you get a nice warning about the missing fields. But if you have the Attachments 2.1 extension enabled, for some reason it gets broken and you'll see an ugly error if you leave any fields blank on comments or discussion submission.
This discussion has been closed.