Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Forum Blank

edited February 2008 in Vanilla 1.0 Help
Hi everyone,

I know a few people have had problems with the forum going blank and I've read a ton of different threads but I'm still screwed.

So I was installing the friendly URL's extension and I went to my forums to see if it worked, and shazam, everything was white. Checked the source and nothing is getting parsed, so I'm assuming something in the innerworkings of vanilla is throwing an error. I can't find anything in my error files or anything, so yeah.

I emptied out my extensions.php file to see if that would clear the problem but no dice. Reinstalling isn't really an option that I want to pursue. Any ideas?

Edit:

Just dug up some errors:

Fatal error: Class 'Context' not found in /users/home/joshuajenkins/web/public/pssrnd07/appg/init_vanilla.php on line 44

So I'm guessing all I need to do is replace whatever file defines Context in it, though I'm not sure which one that would be. Thoughts?

Comments

  • Options
    Friendly URL extension doesn't do anything by itself
    It tells u to use the included .htaccess file and put something in settings.php file

    Did u do that?
  • Options
    Yeah, I did that. Just edited. Got this error:

    Fatal error: Class 'Context' not found in /users/home/joshuajenkins/web/public/pssrnd07/appg/init_vanilla.php on line 44

    Thanks for the reply.
  • Options
    Bump... this has got to be a pretty simple error message for the people that know the forums.
  • Options
    edited April 2007
    include($Configuration['LIBRARY_PATH'].'Framework/Framework.Class.Context.php'); // line 28 ... $Context = new Context($Configuration); // line 44

    Why since you installed .htaccess does php can't find the Context Class?

    Maybe it is not related. Does it works again when you take off the .htaccess?
  • Options
    I already deleted the .htaccess file and restored the settings.php to it's original state.

    The above lines are in the init_vanilla.php already, also the Class.Context.php file is in the library as well.

    This is weird and a pain the butt since I spent the whole last week styling my forum :(

    *sigh*

    Thanks for the response
  • Options
    Okay I'm a moron... my conf/settings.php file that I was supposed to edit for the extension was running on my localhost. I didn't even think to check the paths that would obviously be different on my home server and my live server. So I just had to switch all the paths back.

    Duh.

    Thanks guys.
  • Options
    edited February 2008
    I'm having similar problem, so maybe someone is having some suggestion for me. I did not install anything, my forum vanilla worked for a long whole fine, so it's just started to return blanks in home and categories pages. What should I changed not to have blank home page, I can't find much about it on the forum. PS, I installed new version like update to old and problem gone away...
This discussion has been closed.