Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Does not functions after installed Vanilla 1.1.3

edited April 2007 in Vanilla 1.0 Help
Dear All Experts

I've recently installed a version of Vanilla 1.1.3 which was provided free from my host server.
After installed, I test the Vanilla and found out that I can not do any changes in the Application
Settings like ckecking the box or change the banner name. Its shown the message as below even
after updated to version 1.1.2 Vanilla.


Some problems were encountered
The file could not be opened. Please make sure that PHP has write access to
the /public_html/forum/conf/settings.php file.


Same message pop up when I try to add an extension by checking the box of a selected extention.

I have created a temporary ussername and password so you can login to have a play with the
Appliction Settings and Extensions to get the ideas of what I meant.



URL: www.jt-autobodylines.co.nz
Username: testuser
Password: test123


I'm very much appeciated if anyone could helps, thank you.

Comments

  • Options
    Have you done what the error message told you, and made sure that PHP has write access to the /public_html/forum/conf/settings.php file? For instructions, you can check that Troubleshooting tab at the top of this page. :)
  • Options
    @bjrn

    Thank you for your comment. Actually I don't much or got no idea on how to enable the write access
    to /public_html/forum/conf/settings.php file. does it have to change the codes in the settings.php
    or do I have to do something in the hosting control panel to enable write access? I have looked in the
    Troubleshooting Tap but could not find the right answer for this.

    Once again thank you, your comment is valuable to me. hopefully you and Vanilla members could help
    me to resolve the troubles...I can't wait to see Vanilla up and running on my site. :)
  • Options
    edited April 2007
    Tri2yy2nv, it depends on the application or method you use to access the files on the server.
    I use an FTP application called Interarchy on Mac OS X.
    I simply do a "get info" on the file and adjust the checkboxes as shown below...

    permissions

    The file above is set to 644 or rw-r--r-- these are UNIX permissions.

    Your conf directory should be 777 or rwxrwxrwx


    Look more closely at your FTP application, it should have the option to set permissions.

    Posted: Tuesday, 3 April 2007 at 10:59AM

  • Options
    Sorry I've just found this instruction in the Troubleshooting Tap.

    In order to fix these problems there are two methods for linux/unix servers. You either need to chmod the files so that the web server has permission to edit them, or you need to chown the files so that the web server owns the files and can retain full control over them.

    You can chmod the files so that they are wide open to all users on the server with a command like:

    chmod --recursive 777 /path/to/vanilla/conf/


    So what does that means? :D
    How do I chmod the files and where do I insert the code "chmod --recursive 777 /path/to/vanilla/conf/"?

    Your instructions would be great, thank you.
  • Options
    @wanderer

    Thank you for your comment, I think I start getting the idea. I am using Cute FTP
    I'll go and check it out with your instructions now, again thank you. :)
  • Options
    @wanderer

    Thank you so much, I have changed the permission successfully and the problem has resolved.

    Also thank you bjrn for your value comment too. :)
This discussion has been closed.