Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

errpostbackkeyinvalid?

edited March 2008 in Vanilla 1.0 Help
hi. i'm using vanilla 1.1.2 with a custom theme. when trying to post a comment, i get this error message very often. any ideas if i'm missing something here? and i'm able to post, even if i don't check "remember me" when logging in, if that matters. edit: this happens on a gridserver from mediatemple

Comments

  • Options
    edited April 2007
    Does it always happen or just some time?
  • Options
    unfortunately not always. i have no clue under which circumstances it happens :-/
  • Options
    Did you set a folder for your session?
  • Options
    edited April 2007
    &tis this a vanilla setting, or do you mean some php settings?

    session

    Session Support enabled
    Registered save handlers files user
    Registered serializer handlers php php_binary wddx
    DirectiveLocal ValueMaster Value
    session.auto_startOffOff
    session.bug_compat_42OnOn
    session.bug_compat_warnOnOn
    session.cache_expire180180
    session.cache_limiternocachenocache
    session.cookie_domainno valueno value
    session.cookie_lifetime00
    session.cookie_path//
    session.cookie_secureOffOff
    session.entropy_fileno valueno value
    session.entropy_length00
    session.gc_divisor100100
    session.gc_maxlifetime14401440
    session.gc_probability11
    session.hash_bits_per_character44
    session.hash_function00
    session.namePHPSESSIDPHPSESSID
    session.referer_checkno valueno value
    session.save_handlerfilesfiles
    session.save_pathno valueno value
    session.serialize_handlerphpphp
    session.use_cookiesOnOn
    session.use_only_cookiesOffOff
    session.use_trans_sid00

    the webroot in conf/settings.php is set to "/", as the forum resides in the root dir of the domain


    edit: sorry for that mess, i have no idea what is causing that many linebreaks between those two tables
  • Options
    edited September 2008
    The problem might be that you use the default session path. You should set one for your domains or one for each domain.

    To set a session folder for each domain do as follow. You need to connect the server using ssh with your server admin account (see Obtaining and using SSH; you also need to enable the ssh connection for the Admin account in "WebControl > Server Administrator ").
    Once connected to the server do:echo $PWD
    you get something like that /home/xxxx/users/.home . Now do (replacing xxxx, and forum.domain.com with your own)mkdir /home/xxxx/domains/forum.domain.com/data chmod 710 /home/xxxx/domains/forum.domain.com/data mkdir /home/xxxx/domains/forum.domain.com/data/session chmod 770 /xxxx/domains/forum.domain.com/data/session
    then edit /home/xxxx/domains/forum.domain.com/html/.htaccess. it should look like something like that: AddHandler php5-script .php #path to the session folder php_value session.save_path "/home/####/domains/forum.domain.com/data/session" #Set the time in minute the session will be valid php_value session.cache_expire 180 #Here, it's in second php_value session.gc_maxlifetime 10800 #turn it off when you are done debugging your forum php_flag display_errors On
  • Options
    wow, thanks a lot! :D i'm trying this
  • Options
    one more thing: just out of interest, what's causing the problem respectively what happens exactly if more domains than one share the same session path? are sessions overwritten then?
  • Options
    edited April 2007
    I am not sure if it is related, but from php.net:
    session.gc_maxlifetime integer

    session.gc_maxlifetime specifies the number of seconds after which data will be seen as 'garbage' and cleaned up. Garbage collection occurs during session start.

    Note: If different scripts have different values of session.gc_maxlifetime but share the same place for storing the session data then the script with the minimum value will be cleaning the data. In this case, use this directive together with session.save_path.
  • Options
    ah, ok. just changed it according to your instructions and i'm curious if it works :) at least it looks good after some testing
  • Options
    edited April 2007
    Maybe, you also wanted to know what mean the error message.

    In each vanilla form there is a hidden key, unique to each user and to its session. Before proceeding anything, vanilla compare the key it received with the one in the user session. If they are not the same, Vanilla don't proceed anything and give you the error message. You just need to post again with a valid postbackkey to have you message posted.

    That's why you need to have your php session working properly.
  • Options
    Hi Dinoboff,

    Hope you can help, I followed your instructions to the word, am also on a grid and MT servers, but am still getting the popup message "There was a problem authenticating your post information"

    Im gutted as this only happened after i changed the themes and installed some extensions, and in particular updated to Vanilla 3. Am tempted to roll back, what do you think? is it worth it?
  • Options
    I don't see how a theme could be the problem. An extension could, but it' is unlikely. What is the address of the forum?
This discussion has been closed.