Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Connection to MySQ database failed

edited April 2007 in Vanilla 1.0 Help
I have a vanilla forum running http://munroe.ws/vanillaforum/ I have it hosted on a Linux shared hosting plan with GoDaddy. I wanted to open up the database to remove names. I tried to do this through my hosting Manager Home>Databases>MySQL using which brought up the application phpMyAdmin2.7.0-pl2 Since it didn't respond to my Forum Admin ID and Password, I tried resetting the password. I still couldn't access the database. However, now, although I get a Vanilla Forum login screen when I try to access the forum from the web, any action such as entering my user name and password and then clicking on "Proceed" or Apply for Membership gets a "fatal, non-recoverable error has occured" Error message: The connection to the database failed: Affected Elements MySQL.OpenConnection(); The error occured on or near: Access denied for user: 'mun0708712245012@linhost265.prod.mesal.secureserver.net' (Using pasword: YES) for additional support documentation, visit the Lussumo Documentation website: lussumo.com/docs So, I am pretty sure that by setting a password, I have broken it somehow. I don't want to reinstall and start over because I have users of the forum which hasn't been up long, but it is my highschool class and has been up for about 3 weeks.

Comments

  • Options
    This is me again (mmunroe). Is it possible that the database supporting Vanilla did not have a password previously? And that allowed the application to use it? I know very little about php so this may be a dumb comment. I am sure that it was my setting a password for MySQL database that "broke" my Vanilla Forum. I am just wondering if it could be that there was not supposed to be any password at all. I tried resetting the password again from within the GoDaddy Hosting Manager to " " but GodDaddy requires a password of at least 7 characters containing a minimum of one each, upper case, lower case and numeral. The odd thing is that I still can't open the database within the GoDaddy Hosting interface so, maybe I am looking for the problem in the wrong direction.
  • Options
    if you changed your db password, you have to change it in conf/database.php $Configuration['DATABASE_PASSWORD'] = 'yournewpassword';
    (I am no sure I understand you thought, but your forum user and your db user, the one you use to connect to the db or to phpmyadmin, are 2 different things.)
This discussion has been closed.