Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Problems With The Latest Upgrade

edited April 2007 in Vanilla 1.0 Help
I admit I am not an expert at Vanilla and forum software, but I am running a forum and it has worked well in the past. I saw that there is an update and downloaded it to my hard drive and loaded it up to my forum. Alas, the final result is not doing too well. My first page of discussions does not appear and I cannot add a discussion to the forum.

This is the message you get on page 1 of the discussion pages:Fatal error: Call to a member function on a non-object in /homepages/38/d164002731/htdocs/Vanilla.1.0.1/Vanilla.1.0.1/library/Vanilla/Vanilla.Functions.php on line 18

I think I fouled something up when I tried to reinstall my themes. I had copied them from my original themes but I must have made a mistake somewhere along the line.

My thought to fix it is this: I have a copy of my original set up on Mozy, I can download that to my hard drive and then upload that to my host and overlay the update I put in yesterday. That would get me back to the way it was before I uploaded the update but keep the themes and extensions the way they were.

My question is: am I on the right track here? As I said, I am not an expert at Vanilla and would appreciate your opinions and advice.

Thanks, Fabienne

Comments

  • Options
    MarkMark Vanilla Staff
    The problem is likely to do with your custom discussion.php theme. Take a look at this:

    1.1.1 Upgrade problem # 9
  • Options
    edited April 2007
    Good Lord, Mark, It worked! I am so happy! Of course I have to go back and delouse my CSS which I managed to mess up, but that is a piddling thing compared to the agony I thought I was going to have to go through. Many thanks, Mark. I really appreciate your pointing me in the right direction. I did search for my error message but came up with nothing, but with your help I am up and running again.

    However, when I click on any bookmarked or sticky discussion, I get the error message: Fatal error: Call to a member function on a non-object in /homepages/38/d164002731/htdocs/Vanilla.1.0.1/Vanilla.1.0.1/library/Vanilla/Vanilla.Functions.php on line 18

    Could it be that I have to do the same thing in Functions.php (or some place like that) on line 18 or there abouts? Basically getting rid of the word 'configuration', I am looking for some logic in this even if I don't really know PHP. I did look in the rest of the discussion but did not see anything I thought pertained to that problem. Thanks again.

    ETA: After a good night's sleep and another look at the discussion you mentioned above, that was the next complaint of the people who suffered the same fate that I did. I also went in and eliminated the pesky word in the string in comments.php and now the entire board works well. Thanks thanks thanks, Mark. Sorry to be such a noob. My only excuse is: I'm a noob.
  • Options
    MarkMark Vanilla Staff
    hahaha - no bother at all, fabienne. Glad you got it working :)
This discussion has been closed.