Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Installer fails in step 2

edited April 2007 in Vanilla 1.0 Help
The first parts of my installation went fine. I CHmodded everything, I set up the database username/password. When I clicked the link to go on, though, it tried to open the new .php page as a download, not as a web page. Any reason why that would happen? I'm using Firefox running in Ubuntu.

Comments

  • Options
    Sorry for posting twice, but I tried installing on Windows XP. Firefox 2.0: showed a blank page. Internet Explorer: never stopped loading page. Has anybody else had this problem?
  • Options
    Curious. Sounds like the headers are getting messed up somewhere.

    The download prompt--what do you see if you save the file locally and open it? You might just be able to continue installing from that.
  • Options
    I get a blank page when I open it. It's not really doing anything - it just seems to think that it's handling a file.
  • Options
    Is it possible to execute the database-creating queries manually? The database.php and settings.php are being created, though they each show only one line. If I know where my database is, can I manually create these files and the database, to jumpstart the whole creation process?
  • Options
    edited April 2007
    Yes, there is a SQL file in the installer folder that you can run right at the command line, or even import into PHP My Admin.

    I just so happen to have a basic install setup, and its settings.php contains this:<?php // Application Settings $Configuration['SETUP_TEST'] = '1'; $Configuration['APPLICATION_PATH'] = '/homepages/17/d87887808/htdocs/forum/'; $Configuration['DATABASE_PATH'] = '/homepages/17/d87887808/htdocs/forum/conf/database.php'; $Configuration['LIBRARY_PATH'] = '/homepages/17/d87887808/htdocs/forum/library/'; $Configuration['EXTENSIONS_PATH'] = '/homepages/17/d87887808/htdocs/forum/extensions/'; $Configuration['LANGUAGES_PATH'] = '/homepages/17/d87887808/htdocs/forum/languages/'; $Configuration['THEME_PATH'] = '/homepages/17/d87887808/htdocs/forum/themes/vanilla/'; $Configuration['DEFAULT_STYLE'] = '/forum/themes/vanilla/styles/default/'; $Configuration['WEB_ROOT'] = '/forum/'; $Configuration['BASE_URL'] = 'http://wallphone.com/forum/'; $Configuration['FORWARD_VALIDATED_USER_URL'] = 'http://wallphone.com/forum/'; $Configuration['SUPPORT_EMAIL'] = 'forums@wallphone.com'; $Configuration['SUPPORT_NAME'] = 'David'; $Configuration['APPLICATION_TITLE'] = 'Forums'; $Configuration['COOKIE_DOMAIN'] = '.wallphone.com'; $Configuration['COOKIE_PATH'] = '/forum/'; $Configuration['BANNER_TITLE'] = 'Writing on the Wall'; $Configuration['SETUP_COMPLETE'] = '1'; ?>

    And database.php contains this (username and password modified, of course):<?php // Database Configuration Settings $Configuration['DATABASE_HOST'] = 'dbVanilla.dbhost.net'; $Configuration['DATABASE_NAME'] = 'dbVanilla'; $Configuration['DATABASE_USER'] = 'dbUser'; $Configuration['DATABASE_PASSWORD'] = 'dbPass'; ?>
  • Options
    edited April 2007
    Seems a bit risky, now that I see that, but most of that I know the answer to. Is "homepages" something that is automatically set, or is that something on your site separately? Now I just have to find the SQL queries I need. I'll also try to record a video of an attempted installation, just in case that helps. EDIT: Okay, when I add that information, and change it to match my site, it still thinks it's not installed - probably because the database still doesn't exist. So I need to create the database FIRST, then add that info, and see if it works. EDIT AGAIN: Whoops didn't read your whole post. Running queries now, let's see if that works. FINAL EDIT FOR NOW: Okay, now I get an error when running the query. There seems to be an error in your SQL query. The MySQL server error output below, if there is any, may also help you in diagnosing the problem ERROR: Unclosed quote @ 244 STR: ` SQL: INSERT INTO `LUM_User` (`RoleID`, `StyleID`, `FirstName`, `LastName`, `Name`, `Password`, `Email`, `UtilizeEmail`, `ShowName`, `CountVisit`, CountDiscussions`, `CountComments`, `DateFirstVisit`, `DateLastActive`,`SendNewApplicantNotifications`) values (4,1,'Administrative','User','Admin','Admin','admin@forum.com','1','1',0,0,0,'1975-09-16 08:39:00','2006-04-25 17:38:44','1'); SQL query: INSERT INTO `LUM_User` (`RoleID`, `StyleID`, `FirstName`, `LastName`, `Name`, `Password`, `Email`, `UtilizeEmail`, `ShowName`, `CountVisit`, CountDiscussions`, `CountComments`, `DateFirstVisit`, `DateLastActive`,`SendNewApplicantNotifications`) values (4,1,'Administrative','User','Admin','Admin','admin@forum.com','1','1',0,0,0,'1975-09-16 08:39:00','2006-04-25 17:38:44','1'); MySQL said: #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ', `CountComments`, `DateFirstVisit`, `DateLastActive`,`SendNewApplicantNotificat' at line 2 I see that I need to add a quote, so I'll edit the query and try again later, I guess.
  • Options
    All those homepages paths are specific to my server, and inserted by the installer so yours would be different. They point to the full path on the machine where my site is hosted.

    One way you could find this information is to create a phpinfo.php file containing the one line <?php phpinfo(); ?> and load it in the browser. That will give a bunch of information about your server and configuration, look for the item labled DOCUMENT_ROOT.
  • Options
    Awesome. Thanks, I'll try that ASAP.
  • Options
    Okay, getting somewhere. The SQL query has created me and my main user. Now, when I go to my URL, I get a "Cannot Find Page" message instead of the installer. Boy, what a step forward.

    Here's my settings.php page. Does it look okay? If it does, the problem is with the database, which makes it easier to tweak.

    <?php // Application Settings $Configuration['SETUP_TEST'] = '1'; $Configuration['APPLICATION_PATH'] = '/home/oadmin/public_html/impermanence/'; $Configuration['DATABASE_PATH'] = '/home/oadmin/public_html/impermanence/conf/database.php'; $Configuration['LIBRARY_PATH'] = '/home/oadmin/public_html/impermanence/library/'; $Configuration['EXTENSIONS_PATH'] = '/home/oadmin/public_html/impermanence/extensions/'; $Configuration['LANGUAGES_PATH'] = '/home/oadmin/public_html/impermanence/languages/'; $Configuration['THEME_PATH'] = '/home/oadmin/public_html/impermanence/themes/vanilla/'; $Configuration['DEFAULT_STYLE'] = '/impermanence/themes/vanilla/styles/default/'; $Configuration['WEB_ROOT'] = '/impermanence/'; $Configuration['BASE_URL'] = 'http://omegaseye.com/impermanence/'; $Configuration['FORWARD_VALIDATED_USER_URL'] = 'http://omegaseye.com/impermanence/'; $Configuration['SUPPORT_EMAIL'] = 'ronoxq@omegaseye.com'; $Configuration['SUPPORT_NAME'] = 'Rory'; $Configuration['APPLICATION_TITLE'] = 'OEImpermanence'; $Configuration['COOKIE_DOMAIN'] = '.omegaseye.com'; $Configuration['COOKIE_PATH'] = '/impermanence/'; $Configuration['BANNER_TITLE'] = 'OEImpermanence'; $Configuration['SETUP_COMPLETE'] = '1'; ?>
  • Options
    Looks good to me.

    Now for the timeout problem... my guess is that the server is trying to connect to your database and something is wrong there, so it just stalls, but before it can tell us what is wrong, the browser times out, displaying nothing.

    After double-checking your database settings, the only way to find out what is happening would be to either set the server's timeout earlier than the browsers (or vice-versa), or see if there is an Apache error log somewhere with your host.

    Since you were able to run the SQL, my guess is a bad setting in the database.php file.
  • Options
    Huh. This is getting to be a problem. I'm using the right database query: I set up a vBulletin demo site alongside this, using the same info, and it worked. If I use other information to run Vanilla, I get an error. When I run it RIGHT, though, I get a timeout every time. Are you testing a different version than me? Better yet: is a slightly outdated version available for me to test out? Perhaps it's just the most recent footprint that's causing problems.
  • Options
    edited April 2007
    I'm using the same version. (1.1.2) There are older versions at http://lussumo.com/downloads, not sure if they would make a difference.

    One idea is to edit appg/settingsinit_vanilla.php and comment out the ob_start() command, that way output should ::crosses fingers:: get sent right to the browser instead of being buffered until the page is done rendering. Then if a particular query or process is causing the server to hang we might be able to see where it could be from.

    Of course, this could be a symptom of the same probelm that prevented the installer page to load--maybe install the Live HTTP headers firefox plugin and see what is different in the headers between step 1 and step 2 of the installer.

    EDIT: Noticed that there is another ob_start() in appg/init-vanilla.php, this would be the one to comment out, since buffers are discarded with ob_end_clean before they reach this point and start buffering over.
  • Options
    Nope. Still a timeout. Meaning chances are, it's something going on with the database, right?
  • Options
    The fact that the extension page works and the registration/login pages (I did try regestering an account, but it timed out... curious if it added me) tells me that it is the database.

    I did look at the HTTP headers between the working pages and others, and they weren't helpful--just basically says "found your file..." then timeout.

    I'm not really sure what to do at this point... wish someone else could chime in on this issue. ::hint, hint::
  • Options
    edited April 2007
    Did you happen to locate the server's error log?

    I suppose you could try some basic database connections and queries in a basic extension... Although the query doesn't get much simpler than the one that times out at /ajax/getuser.php?Search=a

    How well do you know PHP?
This discussion has been closed.