Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Localhost problem on vanilla test forum (probably an easy fix)

joemadjoemad New
edited May 2007 in Vanilla 1.0 Help
I've got a vanilla forum set up on my pc to test on the network. Users can't access anything beyond the front page because the code is going to localhost. Does anyone know where to change localhost to my ip address so that everyone on the network can access the forum?

THANKS!

Comments

  • It should already be accessible by your IP. But you probably have a router, firewall, or your ISP might be blocking port 80 (which is the standard port used to transfer the web pages) munging things up.

    Other than that, get a host. 110mb.com is a free host with an environment that supports Vanilla.
  • Thanks WallPhone but I don't think it's a router or firewall. I already have a vanilla forum running on the internet but this is for a small network intranet and will not be accessible outside of the network. I already have a wiki running on my machine and everything seems to work on it. It's access from my ipaddress 192.168.1.69/wiki. I have vanilla on 192.168.1.69/forum. It shows up but when the posts are accessed it switches from 192.168.1.69/forum to localhost/forum... I think it's in the coding and can be changed. I just don't know where. I've been opening different php files and searching but I haven't had any luck yet.
  • lechlech Chicagoland
    Hi joe, in your /conf/settings.php file what's the common entry for $Configuration['BASE_URL'] = ? is that simply localhost? you'll want to tweak settings there to suit your network, alternately you can modify the host file for each computer accessing the network to reference localhost as the ip of the machine running the forum among other little tweaks.
  • joemadjoemad New
    edited May 2007
    Thanks lech! I knew it would be an easy fix. In the /conf/settings.php file "$Configuration['BASE_URL'] = localhost" so I changed it to my ip and bam! It works! Thank you!
This discussion has been closed.