Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Error restoring backup

edited May 2007 in Vanilla 1.0 Help
I'm trying to move my site to a new host, but MySQL keeps rejecting the LUM_Comments table. Can anyone suggest what might be wrong? Here is the first line.

INSERT INTO `LUM_Comment` VALUES (1, 1, 71, '2006-11-29 12:59:59', , '', 0, 'Daniel, we may have our answer.', 'Text', '0', '', 0, '82.153.37.237') ;

The table has been created OK, and the fields in the entries seem to match the table - I have also tried uploading direct, and via BigDump, but it still sticks on this table. All lines in this table throw up the same error.

MySQL: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '', 0, 'Yes I agree Daniel this is pretty', 'Text', '0', '', 0, '80.41.109.45')' at line 1

Comments

  • Options
    Hm. I exported just that table and the import worked. Strange. I will leave my post here in case anyone else has the same problem in future, and see how the rest of the backup goes...
  • Options
    lechlech Chicagoland
    Might be a bit more helpful if you describe how you exported the DB with which application? Depending what you used it should have done a complete mySQL dump of the DB which was virtually clean. I suspect that you're probably missing a comma before or after that line leading into the next entry.
  • Options
    I created a dump with phpmyadmin but the discussion and comments tables caused this error so I had to do those individually.

    Interestingly, I now have my working backup but I have no comments my discussions. Just '0'. The tables are definitely there. Can anyone suggest what might be wrong? I'm not getting any errors.
  • Options
    ignore me. sorry. the database hadn't imported correctly.
This discussion has been closed.