Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Not signed in... (and other similar problems)

edited July 2007 in Vanilla 1.0 Help
Hi, I tryed to install a vanilla forum under ZMWS (http://www.zmws.com) running under Windows (that is no .htaccess is working). No problem for using PHP or MySQL. I also put a read and write access on all the directories. The problem is that I can not sign in. I have the window (people.php) for signing in, put user and password properly, have no error message, but at the end, I'm again on the main screen with the info in the right upper corner NOT SIGNED IN; Many thanks for your help Klod

Comments

  • Options
    Sounds like it's probably a cookie or sessions issue. What do you have set as the cookie domain and path?
  • Options
    For the moment, I try to run Vanilla locally. So : $Configuration['COOKIE_DOMAIN'] = 'localhost'; $Configuration['COOKIE_PATH'] = '/';
  • Options
    You cant use localhost as a cookie domain. Try using 127.0.0.1
  • Options
    Good idea. Have also to change (in conf/settings.php) everywhere there was 'localhost', ie : $Configuration['BASE_URL'] = 'http://127.0.0.1/'; $Configuration['FORWARD_VALIDATED_USER_URL'] = 'http://127.0.0.1/'; $Configuration['COOKIE_DOMAIN'] = '127.0.0.1'; Seems to work. Thanks.
  • Options
    Well, I think I have some other similar problems... Now, I have started a new discussion. But even this an administrator profile (all functions), and even if I have all the choices (bookmark... delete... close... sticky... sink... discussion) on the left and the delete option on the right of the screen, I cannot do any action. I see Vanilla working, but noting is changing... The only possible think is editing the comment ! Another good idea ?
  • Options
    I'm not quite sure I understand what you're saying, but have you tried re-uploading the js and ajax folders and hard refreshing? What browser are you using?
  • Options
    edited July 2007
    I will try to explain... Let's take the action "Bookmark this discussion". On this forum, I have used this option successfully to follow this topic. On my "test" forum, when I click on "Bookmark this discussion" , I see someting happening, the option changed to "Unbookmark this discussion" but that all. By refreshing the page, I can see that this option has not been "saved" Other example : the edit function. On this forum, I can edit my comments. But with the same browser, I cannot do that on my "test" forum. It's probably besause I run this "forum" locally (exactly, on a usb key). But when I start a news project, this is how I work... As I had to rewrite some other lines of settings.php in order to have related paths (and not strict ones - like for example old version > $Configuration['APPLICATION_PATH'] = 'E:/ZMWS/_web.zmwsc/'; => new version > $Configuration['APPLICATION_PATH'] = ''; ...) I first thought that there could be other places were such changers should have been done - but I did not find them. Does that explain a bit better my problem ? Thanks in advance.
  • Options
    How come you changed to having a blank application path? I'd imagine that's bound to cause some problems... Can't you put something in there?
  • Options
    edited July 2007
    You're right : it works better with the old version... But the point with $Configuration['APPLICATION_PATH'] = 'E:/ZMWS/_web.zmwsc/'; is the drive letter E:/ Starting on a usbkey, and depending on the computer, I do not have always the same letter. Any suggestion for another way to write those paths, in a more commun way (without drive) : $Configuration['APPLICATION_PATH'] = 'E:/ZMWS/_web.zmwsc/'; $Configuration['DATABASE_PATH'] = 'E:/ZMWS/_web.zmwsc/conf/database.php'; $Configuration['LIBRARY_PATH'] = 'E:/ZMWS/_web.zmwsc/library/'; $Configuration['EXTENSIONS_PATH'] = 'E:/ZMWS/_web.zmwsc/extensions/'; $Configuration['LANGUAGES_PATH'] = 'E:/ZMWS/_web.zmwsc/languages/'; $Configuration['THEME_PATH'] = 'E:/ZMWS/_web.zmwsc/themes/vanilla/'; I would also like to avoid another problem. As I'm not connected, I always have a error message when there is an action of sending a mail. Is there a way to avoid that (have a redirection of that command for instance) ? Many thanks
  • Options
    Why dont you just mount your USB key to the letter E? Or incase the pc has partitions or cd drives etc pick something like Q which is in the middle of nowhere. To be honest running a web server on a usb drive is bound to cause headaches..
  • Options
    edited July 2007
    OK, let's leave it that way ;) Running a web server on a usb drive allows me to work on my news website whenever I want, where ever I am, ... before hosting the real one somewhere on the web, of course. With ZMWS, it's very easy. You should try it. Many thanks for your help, indeed.
This discussion has been closed.