Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Fresh install.. Discussions pages don't work.

edited July 2007 in Vanilla 1.0 Help
Right after a clean install of Vanilla.. on the main discussions page (whether logged in or not) the first thing you see instead of a list of discussions is: * Warning: DiscussionGrid::include(/public_html/community/themes/discussions.php) [function.DiscussionGrid-include]: failed to open stream: No such file or directory in /public_html/community/library/Vanilla/Vanilla.Control.DiscussionGrid.php on line 82 * But the file exists at that address just fine. anyone dealt with this before? I've installed Vanilla a few times before and never had this issue. .. All other pages work fine except for the discussions pages. for example, categories, settings, all work fine. You can't even START a discussion because you get similar error to the one above about a missing file.


  • Options
    Can you try re-uploading that file just to make sure it's not corrupted somehow?
  • Options
    done and done: i downloaded and unzipped a clean version of vanilla. grabbed that one file and threw it on the server to replace the old. still same issue.
  • Options
    Hmm..that is an odd one. Presumably file permissions are exactly the same on that file as the rest?
  • Options
    edited July 2007
    incase it helps, here is some history:

    originally, the vanilla install was working on sever1.
    server1 was transfered to server2... i reinstalled on server2 fresh.

    server2 was then transfered to server3 which is it's permanent home.

    everything was working except some other weird issues like not being able to see discussions or categories unless you were logged in.
    also, you couldn't delete anything.

    when you tried to delete something, you got an error (can't remember which) and you would be automatically logged out.

    SOOO.. last night i deleted vanilla and the databases and reinstalled fresh.
    ran into the issue so i reinstalled it again.
    then i tried hot swapping that file, as described in my previous post.

    and so here we are.
  • Options
    lechlech Chicagoland
    Were all of these fresh installations or did you move the configuration folders from servers 1 or 2 over to server 3? If so the old path (if they're each different [even slightly]) would explain the error as some files rely on the configuration files while some might not.

    Double check your configuration install paths (relative/absolute/base) and see if this still crops up.
  • Options
    i've delted the whole vanilla folder.. i'm gonna delete the tables.. and then i'm going to reinstall once more using a freshly downloaded and unzipped vanilla package.
  • Options
    is there anything else i should delete or destroy or set on fire before i reinstall?
  • Options
    Nope...files and tables is all there is :)
This discussion has been closed.