Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

locked out of my site + cookie issues

edited July 2007 in Vanilla 1.0 Help
When I first created my site, I noticed that when I'd log in using Internet Explore, I'd immediately get sent to "people.php" which threw a 404 error. But then I could navigate to the homepage manually and use the site fine. In Firefox this was never a problem.

In the last 24 hours, using Firefox, I went into my "Settings" area and changed the cookie fields/paths to "", hoping that would fix the problem in both browsers. As it stand, I now cannot get back into the site at all. Whenever I try to login with Firefox I get sent to a URL called "", which is of course a 404. So the site now works in neither browser.

I have done three or four Vanilla installs before and never had this problem. Any ideas?


  • Options
    edited July 2007
    Looks OK in Safari mate.

    Although the RSS feed is a 404...
    The requested URL, /://, was not found on this server.

    Posted: Monday, 23 July 2007 at 8:04AM

  • Options
    Re: the 404 error, I think that, too, is caused by the path changes I made in the "Settings" area.

    So is my only recourse to access the database manually (phpmyadmin) and change the settings back?
  • Options
    Settings would be changed in conf/settings.php, not the database, so if you're going anywhere for manual editing that would be the place to go. As for the issue..I dont think it's a cookies problem, more an application paths problem. Are you sure that while you were editing your cookie settings you didnt somehow accidentally edit the web path to vanilla or something? Try opening up the conf/settings.php file and pasting any sections you think are relevant (basically any containing a path or something, but not passwords etc) in here and we'll check them out.
  • Options
    Ah, thanks minisweeper. My settings file looks like this:

    <?php // Application Settings $Configuration['SETUP_TEST'] = '1'; $Configuration['APPLICATION_PATH'] = '/data/www/'; $Configuration['DATABASE_PATH'] = '/data/www/'; $Configuration['LIBRARY_PATH'] = '/data/www/'; $Configuration['EXTENSIONS_PATH'] = '/data/www/'; $Configuration['LANGUAGES_PATH'] = '/data/www/'; $Configuration['THEME_PATH'] = '/data/www/'; $Configuration['DEFAULT_STYLE'] = '/themes/vanilla/styles/default/'; $Configuration['WEB_ROOT'] = '/'; $Configuration['BASE_URL'] = ''; $Configuration['FORWARD_VALIDATED_USER_URL'] = ''; $Configuration['APPLICATION_TITLE'] = 'AlbemarleSoccer'; $Configuration['BANNER_TITLE'] = 'AlbemarleSoccer'; $Configuration['COOKIE_DOMAIN'] = ''; $Configuration['COOKIE_PATH'] = ''; $Configuration['SETUP_COMPLETE'] = '1'; $Configuration['LAST_UPDATE'] = '1184803563'; $Configuration['ADDON_NOTICE'] = '0'; ?>

    Can you suggest any corrections? I suspect maybe the cookie path and domain settings are wrong.
  • Options
    I found at least part of the problem. Viewing source, I noticed the sign-in link looks like this:

    <a href="/people.php?ReturnUrl=://">

    What parameter do I change to make it look like this:

    <a href="/people.php?ReturnUrl=">

    In any case, when I manually visit this page in the browser...

    ...and log in, it now successfully takes me to the homepage, but still does not log me in!
  • Options
    edited July 2007
    One step closer....

    I can now log in and out successfully, so long as I'm doing it from people.php. The ReturnUrl bit seems to be screwing things up; the link is still formatted like this:

    <a href="/people.php?ReturnUrl=://">

    Frustrated, I went ahead and hard-coded this line into menu.php:

    <a href="/people.php">'.$this->Context->GetDefinition('SignIn').'</a>

    I'd still like some feedback on whether my conf file looks okay.
  • Options
    Try: $Configuration['COOKIE_DOMAIN'] = ''; $Configuration['COOKIE_PATH'] = '/'; Also try adding this line before the final ?>: $Configuration['FORWARD_VALIDATED_USER_URL'] = '/';
This discussion has been closed.