Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Problem after Changing URL

edited July 2007 in Vanilla 1.0 Help
little background: I'm working on transferring a current communityserver.org installation over to a wordpress/vanilla setup.(love vanilla btw) Anyway been working on this for like 3 months, got the wordpress and vanilla integration done quite easily, built a style for both wordpress and vanilla, and everything was working great, posting, fck editor(except for in ie7?!), login on both wordpress and vanilla. I made a vb.net program to connect to the mssql db and the mysql db and transfer all the files over to vanilla and wordpress. so I had my 500 some odd posts, 80 discussions, users, and images(in wordpress)+comments. not only did it work, it worked really well, i used a load testing program on it and the old site and it actually outperformed my commuinityserver installation on larger numbers of users(CS was faster for like 1-5 active users, got WP+Van up to 24 with avg serve times under a sec) so it was(i though) all ready to go live, so I switched it from the test domain test.theupstageclub.net to the live one theupstageclub.net, and changed the conf.php in van and wp to the new domain. then I noticed that when I loaded the search page it would just give a blank screen? no headers, nothing. ditto for the user/role settings tab+the new registration tab, the rest worked..!??! so I disabled all the extensions I had on, both in WP and Vanilla, same thing. figured maybe it was a theme thing, so I replaced my style with the original. with that on it wouldn't load anything at all, so I switched it back and returned to the previous brokenness(that a word?) I checked and rechecked everything I could think of, even reuploaded all the original files(less config and wp integration witch I checked 100 times), at this point it was getting late, so I figured I'd just swtich it back to the test domain for now and try again later. switched it all back to test.theupstageclub.net, and now i'm getting just blank pages for everything in vanilla, wp is fine(cept photos) but van isn't even sending headers. I tried making a fresh install of van and just changing the url on that, and it's giving me the same thing, white screen all pages. the WP part works great, I can login, change stuff, whatever(except for the photo section.. thats doing the same thing.. i used fgallery for that, a plugin in wp, also modified) sorry that got kinda long, but its been a process.... any ideas? windows 2003 - IIS

Comments

  • Options
    A good start is to check conf/settings.php in your production vanilla folder and make sure the following variables are correct for your environment:
    • APPLICATION_PATH
    • DATABASE_PATH
    • LIBRARY_PATH
    • EXTENSIONS_PATH
    • LANGUAGES_PATH
    • THEME_PATH
    • WEB_ROOT
    • BASE_URL
    (Dunno why some of these don't reference others...)
  • Options
    Heres my conf.php: path/to is the correct path to theupstageclub folder. // Application Settings $Configuration['SETUP_TEST'] = '1'; $Configuration['APPLICATION_PATH'] = 'path/to/theupstageclub/forums/'; $Configuration['DATABASE_PATH'] = 'path/to/theupstageclub/forums/conf/database.php'; $Configuration['LIBRARY_PATH'] = 'path/to/theupstageclub/forums/library/'; $Configuration['EXTENSIONS_PATH'] = 'path/to/theupstageclub/forums/extensions/'; $Configuration['LANGUAGES_PATH'] = 'path/to/theupstageclub/forums/languages/'; $Configuration['THEME_PATH'] = 'path/to/theupstageclub/forums/themes/vanilla/'; $Configuration['DEFAULT_STYLE'] = '/forums/themes/vanilla/styles/default/'; $Configuration['WEB_ROOT'] = '/forums/'; $Configuration['BASE_URL'] = 'http://test.theupstageclub.net/forums/'; $Configuration['FORWARD_VALIDATED_USER_URL'] = 'http://test.theupstageclub.net/forums/'; $Configuration['SUPPORT_EMAIL'] = 'my@email.com'; $Configuration['SUPPORT_NAME'] = 'Geoff Potter'; $Configuration['APPLICATION_TITLE'] = 'The Upstage Club Forums'; $Configuration['BANNER_TITLE'] = 'The Upstage Club Forums'; $Configuration['COOKIE_DOMAIN'] = ''; $Configuration['COOKIE_PATH'] = '/'; $Configuration['SETUP_COMPLETE'] = '1'; $Configuration['LAST_UPDATE'] = '1178728140'; // Wordpress Authenticator $Configuration['AUTHENTICATION_MODULE'] = 'People/People.Class.WordpressAuthenticator.php'; $Configuration['ADDON_NOTICE'] = '0'; $Configuration['MAX_COMMENT_LENGTH'] = '7000'; $Configuration['DEFAULT_ROLE'] = '3'; $Configuration['ALLOW_IMMEDIATE_ACCESS'] = '1'; $Configuration['ENABLE_WHISPERS'] = '1'; $Configuration['DISCUSSIONS_PER_PAGE'] = '20'; $Configuration['COMMENTS_PER_PAGE'] = '20'; $Configuration['SEARCH_RESULTS_PER_PAGE'] = '20'; $Configuration['COMMENT_PROTECTION_SETUP'] = '1'; $Configuration['DISCUSSION_TAGS_SETUP'] = '1'; $Configuration['NOTIFY_SETUP'] = '1'; $Configuration['NOTIFY_ALLOW_ALL'] = '1'; $Configuration['NOTIFY_ALLOW_DISCUSSION'] = '1'; $Configuration['NOTIFY_ALLOW_CATEGORY'] = '1'; $Configuration['NOTIFY_VERSION'] = '1.2.0'; $Configuration['NOTIFY_AUTO_ALL'] = '0'; $Configuration['EXTENSION_POLL_VERSION'] = '1.3'; $Configuration['USER_WALL_SCHEMA_VERSION'] = '1.0'; $Configuration['USER_WALL_COMMENTS_PER_PAGE'] = '5'; $Configuration['EXTENSION_VOTE_VERSION'] = '1.0'; only think I see thats weird is the cookie domain, but if i rember correctly thats what its suspost to be set to so that wordpress can share the cookie with vanilla.
  • Options
    If this is your production config, I would assume that BASE_URL and FORWARD_VALIDATED_USER_URL should point to http://theupstageclub.net/forums/ instead of what's up there. Unless I'm missing something?

    Does the primary domain have the same doc root as the "test" subdomain?
  • Options
    edited July 2007
    Sorry I should have explained that better, heres the setup theupstageclub.net is the production setup, currently mapped to the old forum system(since its live) when I moved vanilla to the live setup I changed those lines like you said. right now I'm just trying to get it to work on the test domain again, test.theupstageclub.net/forums (main root is Wordpress, vanilla is in the forums sub folder) both domains point at diffrent doc roots(right now) although when I had vanilla live they pointed at the same place. edit-- oh and my base url maps to the same directory as application path, thats right isnt it?
  • Options
    lechlech Chicagoland
    You're going to want to make sure the document roots reflect the server each installation is on. Given if you change servers they might differ to varying degrees so you'll want to map the correct path. Make sure you have a clean backup of the database as well before you started all of this and make backups along the way so you can fall back on the previous if you need to. The only thing you're going to encounter as a problem in rare cases are styles associated with the installation. If you're versed in SQL you can do this manually by editing the SQL dump file or if it's already on the server access phpMyAdmin or similar and check the paths in the LUM_Style table. Other than that make sure your config checks out and has the appropriate permissions to take on changes at your new location.
  • Options
    edited July 2007
    I never changed the directory that vanilla resides in, so the path, server wise should be the same, so the style issue isn't my problem(plus i removed all the styles from the theme, and just incorporated them into the wordpress theme) the only change i made was trying to access the forums using a diffrent url, after changing the conf.php settings(and wp's settings)... well i also added some extensions but i removed them and its still doing it.
  • Options
    If you haven't tried restarting the IIS and PHP services, might be worth a shot. I've had problems with silent PHP crashes on IIS in the distant past. Other than that, I'm stumped; sorry. :)

    (I'm a Debian/Apache2 guy.)
  • Options
    Ok this is weird.... not sure why but for some reason if i change: // By cleaning the output buffer and restarting, it makes downloading work // properly with utf-8 encoding (this was a bug in previous versions). // http://lussumo.com/community/discussion/4442/ ob_end_clean(); ob_start(); to: // By cleaning the output buffer and restarting, it makes downloading work // properly with utf-8 encoding (this was a bug in previous versions). // http://lussumo.com/community/discussion/4442/ ob_flush(); <----- ob_start(); in: appg/init_vanilla.php it shows the page!?!?!? wtf! I can only assume that this will break downloading.. or i'd just leave it, plus it makes no sense, that code shouldn't be at all dependent on the url, yet when the url changes it breaks(verified with another installation), works fine before that. I'm on shared hosting so I cant restart iis and php to see if that would fix it, anyone else use vanilla on windows 2003 with iis? you guys have any suggestions?
  • Options
    Ah Ha! Got it, I had compress articles on in wordpress, apparently that was messing with the buffering in vanilla.. still not sure why flushing it made it work but I can change it back if compression is off in WP... humm... any ideas on how to get compression to work here? I've got alot of users on dial up and compression would really help them.
This discussion has been closed.