Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Problems staying signed in

blizeHblizeH ✭✭
edited August 2007 in Vanilla 1.0 Help
Hi guys,

For some reason, even when you tick the 'Remember Me' button on the login page, if you close your browser it logs you out completely. Also logs you out after 5 minutes or so of inactivity which is highly annoying :(

Any suggestions please?
«1

Comments

  • Options
    Cookie problems I think..what do you have them set as?
  • Options
    $Configuration['COOKIE_DOMAIN'] = 'casino.zestdesign.net';
    $Configuration['COOKIE_PATH'] = '/';

    I think the hosting is a bit dodgy :E
  • Options
    try just .zestdesign.net
  • Options
    Cheers Mini, it's currently set to:

    $Configuration['COOKIE_DOMAIN'] = '.zestdesign.net';
    $Configuration['COOKIE_PATH'] = '/';

    Still not keeping me logged in though :(
  • Options
    Do you use cookies anywhere else on the server to confirm they're working correctly?
  • Options
    Hmm, not on the same domain but I'm pretty sure this is hosted on the same server/hosting package: http://forum.respectlife.org.uk/
  • Options
    Hmmm...well in that case it should be fine. Is there anything else perculiar about the forum?
  • Options
    blizeHblizeH ✭✭
    edited August 2007
    Not at all, but fwiw we tried moving the G! forum onto the hosting and never could get it working either, kept forgetting us. He's contacted the host but they just said to ask the forum developer, d'oh
  • Options
    If you moved the G! forum with no changes whatsoever then it should work fine...
  • Options
    Nope, unfortunately it just wouldn't keep people signed in, my mate ended up moving it to his other hosting (his works hosting) and it was logging people back in again. This casino thing now is hosted with IXWebHosting who have said they've got no idea what the cookie domain should be and that it's specific to Vanilla?
  • Options
    I've got no idea who IXWH are but it would seem that if a forum that worked was moved to them and stopped working, then moved away and it started, there's a problem with the host. The cookie domain should match whatever URL you type in the addressbar - here it's .lussumo.com because then the cookie works for any subdomain of lussumo (i.e. either www.lussumo.com or just lussumo.com)
  • Options
    Excellent cheers Mini, so casino.zestdesign.net with the path of '/' should work just fine? I think it's on Windows hosting, not sure if that makes any difference.
  • Options
    casino.zestdesign.net should do fine, yeah. We always recommend just .zestdesign.net for the reasons I explained above but that's generally more applicable for people using www. If the forum is only ever accessed through that subdomain then that should be fine.
  • Options
    Yup, it's only ever accessed via that subdomain but I'll change it anyway. The path of '/' doesn't have to be changed for a subdomain does it?
  • Options
    Not unless it's casino.zestdesign.net/something
  • Options
    Nope, it isn't :(
  • Options
    Is there any way it can actually be the hosting though? I mean... Well, I dunno. Surely I've just got it setup incorrectly somehow?
  • Options
    It's always a possibility, but as I say, if you run the exact same forum on 3 different hosts and it works on 2 but not on 1 it would seem to me to be an issue with the hosting... Have you tried completely reinstalling vanilla?
  • Options
    Yeah, tried re-installing it twice! :( When I say the same forum, the only thing that's been moved is the sql and a few extensions, the actual configuration files have changed each time
  • Options
    Why?
This discussion has been closed.