Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

www cookie issue (resolved)

edited August 2007 in Vanilla 1.0 Help
I should apologise first for not really understanding any of this - I looked though the stuff on here about localhost and cookies but I still don't really get it. my forum is at and I'm having problems with my application settings/forward address/cookie domain $Configuration['COOKIE_DOMAIN'] = ''; $Configuration['COOKIE_PATH'] = '/forum/'; $Configuration['WEB_ROOT'] = '/forum/'; $Configuration['BASE_URL'] = ''; $Configuration['FORWARD_VALIDATED_USER_URL'] = ''; is how it's set up now there are no subdomains on my site so that shoudn't be a problem but other areas of the site may have other logins so i'd prefer no to keep the cookies at root. I've tried changing things to remove the www from all of those instances but this causes a file not found error. At the moment users are logged in if they have www in the title bar and not logged in if there is no www. Some links, such as the discussiuons tab go to the www but others don't. It's all very annoying :( thanks in advance for your help and for reading this


  • Options
    Just take the www out of the cookie domain---but leave the dot. It should read ''; This will allow the cookie to be read on either www or not. Cookie path can stay the same as well as the other URLs, although you might want to make the cookie path '/' if you still have problems. The cookies are named 'lussumocookie' to help prevent them from interfering with other login systems you might have.
  • Options
    I think that's solved the issues - it works now so I'll do a backup! Big thanks
  • Options
    ithcyithcy New
    edited August 2007
    great forum, conrad.
    i think MurdarMachene would be a great fit there.
  • Options
    thanks - yeah all memes are friends
This discussion has been closed.