Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Allowing Curly Quotes

edited September 2007 in Vanilla 1.0 Help
Has anyone else come across the inability to allow messages to be posted within Vanilla that contain curly quotes (ie. blocks of text that contain curly quotes copied from microsoft word, outlook, etc and pasted into vanilla.) The text gets cut off and only the message up until the first curly quote, single curly quote apostrophe, etc.. gets posted and the rest of the message is not posted. This could be a database issue wherein the tables are set to receive utf-8 characters and the curly quotes may be latin based windows formatted characters. Has anyone found or can anyone think of, off the top of their head, a way to implement this ability into Vanilla. Thank's

Comments

  • Options
    testing microsoft word based curly quotes in this version of vanilla by pasting from microsoft word a sentence of text that contains an apostrophe and quote below: Alex’s house is great to “see” at night.
  • Options
    edited September 2007
    On this forum this copy and setup of vanilla forum 1.1.2 appears to accept curly quotes(as seen in the sentence above), however, is anyone else having or has anyone else had this issue within their setup of Vanilla 1.1.2 not accepting curly quotes? Difference: straight single quote ' curly quote from microsoft word ’
  • Options
    I think you're on the right track--something missmatched between character encodings.

    This may help.
  • Options
    edited September 2007
    Going into the LUM_Comment Table in the mysql database and changing the "Body" field type from text to mediumblob seems to have resolved this issue for now. Thanks for your consideration and response WallPhone. I will look over that info too.
  • Options
    Works fine in my test forum... http://exhibitq.com/talk/discussion/4/lightbox-test/#Comment_57 I've not changed anything in my database AFAIK.
  • Options
    This seems to be controlled by the browser and its “Text Encoding” setup, manual entry works here too. By “manual” entry I mean the keyboard not cutting and pasting from MS Word.

    I tend to avoid such characters, especially in emails as they are often replaced by question marks. I have a couple of spaces in my signature which is always quoted back to me as unknown characters, usually by Outlook, either flavour!

    Posted: Wednesday, 12 September 2007 at 8:35AM

This discussion has been closed.