Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Can't create new categories in a brand new installation of Vanilla.

edited September 2007 in Vanilla 1.0 Help
Installed Vanilla; the database tables seem to have been created just fine; I've got a couple of people signed up with member accounts, but no posts yet; I went to create a new category beyond General and hit this error: Error Message An error occurred while retrieving categories. Affected Elements CategoryManager.GetCategories(); The error occurred on or near: Can't create/write to file '/home/mysql/#sql_7089_0.MYI' (Errcode: 2) 2 is "file not found," if I remember correctly, but I have no idea why it can't be found. Nor why Vanilla could set up other aspects of itself just fine and then balk here. Help? --Thanks.


  • It may be that your host has had some kind of database issue. It's probably worthwhile checking things over with them or just trying again in a while. If you still have no luck we could look into it a bit further. It's quite strange that it cant create stuff yet (presumably) viewing member accounts and stuff (which naturally also accesses the database) works fine?
  • It appears to have been strictly temporary; I just went back to check and the category I'd tried to create was there! (I hadn't done anything to it since getting the error message.) So I tried to create another category. No problems! So: huh.
This discussion has been closed.