Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Lost Settings and No-Show Forum

edited September 2007 in Vanilla 1.0 Help
Yesterday, I changed the characters on my forum setttings from 512,000 to 612,000. I then changed it back to 512,000. This morning, the forum came up and was working fine. When I tried to access it this afternoon/evening, I got the Vanilla upgrade/install page. My Config. settings.php file is 0kB, blank-o. I have had the Vanilla 1.1.2 install since June, but not this latest upgrade. I don't know if any of this is related. Could someone help me with this? Thanks. The following is what comes up online instead of my forum: Vanilla 1.1.2 Setup Installing Fresh If you are creating a brand new installation of Vanilla, all you need to do is upload all of the Vanilla files to your server. Once you are finished uploading, open this file in your web browser and click the install link below. Click here to install a completely brand new version of Vanilla Upgrading If you are upgrading from Vanilla 1.x, read the upgrade instructions online. If you are upgrading from Vanilla 0.9.2.x, here are a few things you should do first: Back up your Database The upgrader will be performing structural changes on your database, you should have a backup of your old database just to be safe. Back up your old Vanilla files Download and save your old Vanilla files to your local machine. Specifically, we can use your old appg/settings.php file for importing old settings. When you are finished backing everything up, upload all of the new Vanilla files to your server, open this file in your web browser and click the upgrade link below. Click here to upgrade from Vanilla 0.9.2.x to Vanilla 1.1.2


  • I replaced the settings that were missing, but my forum still shows Vanilla page. Can anyone help me on this. I'm not sure if this is related somehow to the newest upgrade or not. I really don't want to undertake an upgrade. Is it possible that not upgrading is causing this; if so, then why? Thanks.
  • Dont worry too much about upgrading just yet - 1.1.2 is the latest stable release. What's odd is that you're saying if you upload a valid copy of conf/settings.php (presumably from a backup?) the forum doesnt come back up?
  • Make sure the following line is in your newly uploaded /conf/settings.php$Configuration['SETUP_TEST'] = '1';
  • Okay, thanks Stash. I appreciate the response.
  • Did you have it? Did it make a difference?
  • Hey Texafina, that was no whisper, the entire planet can see it! pic

    Posted: Sunday, 23 September 2007 at 8:33AM

  • Why should it need to be a whisper? You never thank people in public?
  • Uh-oh! Thanks!
  • Hey Sweeper, didn't see you there....I originally just saw Stash's answer. Love your smiley, Wanderer, and "back at you." Yes Sweeper I uploaded a backup copy of the setting; the forum came back on, but the notation below popped up when I tried to sign in as you could see in my whisper. I'll copy it here so that EVERYONE can see it and won't be suspicious of any backroom shennanigans with Stash and me, lol. This is what comes up when I try to sign in on my forum: "Some problems were encountered The file could not be opened. Please make sure that PHP has write access to the /home/directory/www/ file." I have "Write, Read" checked on the permissions on the file, which has always been the case. Earlier when I whispered to Stash, I didn't want to expose my forum guts, as I'm not knowledgeable enough to know just how much public exposure leaves me vulnerable. Hopefully, the "entire planet" didn't get a load of me dropping my drawers.
  • Okay guys, thanks for holding my hand, waving at me, etc., etc. I have my forum operating again. I had to change the User ID and the Group ID on my settings file.....who knew. Gracias.
This discussion has been closed.