Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Clipboard error: ClippingManager doesn't exist

peapea New
edited August 2005 in Vanilla 1.0 Help
Hmm, I can't figure this one out. I've enabled the clipboard Extension and when I try to select a clipping to insert into my post, it gives me the following message:
A fatal, non-recoverable error has occurred

Technical information (for support personel): Error Message: The "ClippingManager" class referenced by "ClippingManager" does not appear to exist. Affected Elements: ObjectFactory.NewObject();


  • This is the actual code that I get in my post field after I've selected an item from my clipboard.

    I've tried accessing /tools/getclipping.php?c=3 where 3 is the id of my clipping, and that - quite expectedly - spawns the same error.
  • I'm running Vanilla 0.9.2 and Clipboard 1.0, by the way.
  • peapea New
    edited August 2005
    I've tried echo'ing the $Context->SelfUrl at the bottom of the comments.php page, but I get:

    Notice: Undefined property: SelfUrl in /home/.dallas/meh/comments.php on line 86

    Maybe that's the reason?
  • I noticed the same thing in our forum, but I forgot to post it.

    So, uh..ditto.
  • so humhum's moving over to vanilla?

  • Yes, eventually. We'll be making a bunch of extensions first, though. I'm thinking it will take a few months...

    In the end it's a nice move towards making the forum more expandable. Members will be able to propose extensions etc. And the Vanilla framework is sweet!
  • is the file in the extensions directory?
  • peapea New
    edited August 2005
    Yeah, the Clipboard.php file is in the extensions directory and the extension is enabled.

    It all works until it tries to read the clippings to put them into a post - then it says the class isn't defined.
  • MarkMark Vanilla Staff
    edited August 2005
    Wow. I can't believe no-one else found this bug before now.

    It has to do with the fact that extensions aren't included in the init_ajax.php file, so when the ajax page for the clipboard loads, it doesn't have the correct class included. I think the easiest fix for this one temporarily would be to open up the tools/getclipping.php file and after the include("../appg/init_ajax.php"); line, include the extension file for the clipboard, like this: include("../extensions/Clipboard.php");

    That should solve the problem for the time being (until I do the next rev when I'll come up with a better solution).
  • Maybe, due to the use of Ajax, it's worth mentioning that I'm using Safari 2.0.

    And since dknowles is also experiencing this, I guess I should post a bug report.
  • yeah i just tested it... and foudn the same thing... but it seems mark knows alreadyt
  • peapea New
    edited August 2005
    Then again, maybe I shouldn't! ;') Thanks Mark! I'll try that out.
  • yeah, josh (jsanders) and i noticed this like a week or two ago. we're just dumb and forgot to say anything about it.
  • peapea New
    edited August 2005

    That first solution works just fine. You're a star, Mark. Thanks again.
  • MarkMark Vanilla Staff
  • edited August 2005
    except, on *nix, it's Clipboard.php
  • okay, i've tried my hardest to bold the capital 'C' but it's just not working too well. you get the point.
  • MarkMark Vanilla Staff
    changed :)
This discussion has been closed.