Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

How do I remove the Sign In button on the top right?

edited January 2008 in Vanilla 1.0 Help
Hi. I have been having problems with the top right "Not signed in [sign in]" area. I have got the guest sign in on the panel extension and it works perfectly. I get a 403 error on that sign in whenever I click it. So basically I want it gone. :) I like the idea of showing yourself as signed in up there but I want to get rid of the actualy Sign In link. I hope I'm making sense.
Showing that you are signed in is great but the sign in link does not work and I want it gone if I can. Any help is very appreciated!! Thanks!!

Comments

  • Options
    You can do it the easy way or the hard way! :)

    The easy way:

    #Session {display: none;}

    The hard way:

    Look in theme/menu.php line 4-12 .
  • Options
    Thank you for your help. I'm not very bright, so I'll take the easy way. :) What file do I edit? Thank you!
  • Options
    sjeepssjeeps
    edited September 2007
    Well if you still want to keep the 'Signed in as xxx (Sign out) link, just delete line 9 and 10 in themes/menu.php

    Change this:

    echo '<div id="Session">'; if ($this->Context->Session->UserID > 0) { echo str_replace('//1', $this->Context->Session->User->Name, $this->Context->GetDefinition('SignedInAsX')).' (<a href="'.$this->Context->Configuration['SIGNOUT_URL'].'">'.$this->Context->GetDefinition('SignOut').'</a>)'; } else { echo $this->Context->GetDefinition('NotSignedIn').' (<a href="'.AppendUrlParameters($this->Context->Configuration['SIGNIN_URL'], 'ReturnUrl='.GetRequestUri()).'">'.$this->Context->GetDefinition('SignIn').'</a>)'; } echo '</div>';

    To:

    echo '<div id="Session">'; if ($this->Context->Session->UserID > 0) { echo str_replace('//1', $this->Context->Session->User->Name, $this->Context->GetDefinition('SignedInAsX')).' (<a href="'.$this->Context->Configuration['SIGNOUT_URL'].'">'.$this->Context->GetDefinition('SignOut').'</a>)'; } echo '</div>';
  • Options
    THANK YOU!!! You're my hero!
  • Options
    It worked and you are the best!! You have no idea how much better I feel. I spent hours trying to figure out how to get that link working or get rid of it. Wow. Thank you!!
  • Options
    I have the same problem, but I'd like better not to get rid of the link, but to function. Description of the problem: http://forum.0511web.de (just a test!) I am not signed in and when I call the URL above, there's an error: "Forbidden You don't have permission to access /people.php on this server." It's a 403. In my browser the URL http://forum.0511web.de/people.php?PageAction=SignOutNow&ReturnUrl=http://forum.0511web.de/ is shown. When I type directly http://forum.0511web.de/people.php everything is okay. But this is not okay, that I have to type manually the right URL. I have PHP Version 5.2.3, on Linux, Session Support: enabled, the right session.save_path in Settings. Unauthorized people are not allowed to view the forum. When I am testing with unauthorized are allowed, the Login-Link gives me the same error as above: URL after click: http://forum.0511web.de/people.php?ReturnUrl=http://forum.0511web.de/ You don't have permission to access /people.php on this server. Is there a solution, I did not found anything in this forum since now. Thanks for help, greetings!
  • Options
    It's probably some security thing that is breaking it.... We've seen something like this before but I can't remember what was causing it... here ya go: http://lussumo.com/community/discussion/7061/
This discussion has been closed.