Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

IE CSS issue (default theme/style)

edited October 2007 in Vanilla 1.0 Help
I know IE sucks...

I was tweaking the default style, and added some margins & padding to #Content:

#Content { margin:0px 5% 0px 5%; padding-left:235px; }

Everything looks fine in Firefox, but in IE the discussion count on the bottom of the screen is doing some funny. It's hanging out in the right margin for some reason.

Any ideas what's going on? What classes/id's should I be looking at to figure out what's wrong?



  • Options
    Here?: Bug? "1 to 1 of 1" appears on right, instead of below...

    And maybe (though too tired to make sense of the bookmark right now)?: 'All discussions' position in IE
  • Options
    You may want to try Vanilla 1.1.3 also, both those CSS bugs pbear pointed out are fixed in it.
  • Options
    I thought his board was running v. 1.1.3! But maybe his mods are undoing the fix. hmmm... now that I check again, the version is not posted.
  • Options
    You know, it probably is 1.1.3 because the "All Discussions" is on the left.

    As far as the issue... it appears the same ans what pbear pointed out--the margin is creating a blank space that the page numbers are small enough to fall up through. I would suggest adding margins instad as padding on a higher level--as padding on #Content or HTML.
  • Options
    edited October 2007
    I am using v1.1.3... not sure what to say. I don't think any of my extensions should be messing with the theme/style... except for CategoryRoles, which adds a pseudo-theme. Could that be the culprit?

    Anyway, following the advice on one of those pages pbear linked to, I added a clear property:
    html>body #Content .ContentInfo.Bottom .PageInfo { border-top: 1px solid #fff; clear: left; /* Fix for IE margins (10-5-07) */ }
    This positions the "X to Y of Z" correctly now, but the top border above the element disappears. Not perfect, but in lieu of a real fix I guess it can stay that way.
  • Options
    edited October 2007
    Ahh! I fixed it. Adding the clear moved the element up a few px. Adding a small margin seems to have fixed it:

    html>body #Content .ContentInfo.Bottom .PageInfo { border-top: 1px solid #fff; margin-top: 3px; /* Fix for IE margins (10-5-07) */ clear: left; /* Fix for IE margins (10-5-07) */ }

    Everything looks the same in Firefox.
This discussion has been closed.