Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Fatal Error when "Keep me Logged In" is checked

edited October 2007 in Vanilla 1.0 Help
Notice: Undefined index: TableName in /home/dunbarch/public_html/ophelon/Vanilla-1.1.3/library/Framework/Framework.Class.SqlBuilder.php on line 216 Notice: Undefined index: TableAlias in /home/dunbarch/public_html/ophelon/Vanilla-1.1.3/library/Framework/Framework.Class.SqlBuilder.php on line 217 Notice: Undefined index: u in /home/dunbarch/public_html/ophelon/Vanilla-1.1.3/library/Framework/Framework.Class.SqlBuilder.php on line 263 Notice: Undefined index: in /home/dunbarch/public_html/ophelon/Vanilla-1.1.3/library/Framework/Framework.Class.SqlBuilder.php on line 263 Notice: Undefined index: u in /home/dunbarch/public_html/ophelon/Vanilla-1.1.3/library/Framework/Framework.Class.SqlBuilder.php on line 263 Notice: Undefined index: in /home/dunbarch/public_html/ophelon/Vanilla-1.1.3/library/Framework/Framework.Class.SqlBuilder.php on line 263 A fatal, non-recoverable error has occurred Technical information (for support personel): Error Message An error occurred while attempting to validate your remember me credentials Affected Elements Authenticator.GetIdentity(); The error occurred on or near: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'from where u. = '1' and u. = '25d4cf6b00d15204270e68a1e2baf4e1'' at line 1 For additional support documentation, visit the Lussumo Documentation website at:


  • Options
    I'm assuming you mean "Remember me" ?

    Why not update to 1.1.4 while you're at it?

    Sorry I can't help you with the actual issue, but it looks like it's having problems with the cookie session.
  • Options
    I forgot to include: Apache version 1.3.37 (Unix) PHP version 5.1.6 MySQL version 5.0.27-standard-log @ Wanderer - I did the upgrade to 1.1.4 hoping it would solve the problem, but it didn't change a thing. I thought so too, so I did the cookie fix ''; and it didn't help. I can't log in unless I delete my cookie - so the cookie must be doing something.
  • Options
    Reinstall library/Framework/Framework.Class.SqlBuilder.php and library/People/People.Class.Authenticator.php
  • Options
    Thank you Dinoboff. Works like a charm now. :)
This discussion has been closed.