Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

fixing mySQL databases after transfering domain - HELP!

edited November 2007 in Vanilla 1.0 Help
I had a few standard hosting accounts with Godaddy before I realized that a deluxe account would be much better (money wise). I have my entire forum backed up including the mysql database. Transfered everything over to the new hosting account, which requires the site to now be in a sub-folder instead of the root. The problem is that the mysql databases are only in the root folder, so it looks like my forum doesn't know where to look for the mysql database. How can I fix this problem? You can see the error messages here: http://www.coltsalumni.org/forum It looks like the problem is in the /appg/init_vanilla.php file but I don't know what to change to fix it. Thanks in advance for the help!

Comments

  • Options
    in conf/settings.php, replace any reference to /home/content/c/o/l/coltsalumni/html/forum/ by /home/content/b/e/n/bengoheen/html/coltsalumni.org/forum/

    eg: $Configuration['DATABASE_PATH'] = '/home/content/c/o/l/coltsalumni/html/forum/conf/database.php';
    should be $Configuration['DATABASE_PATH'] = '/home/content/b/e/n/bengoheen/html/coltsalumni.org/forum/conf/database.php';
  • Options
    I changed the settings to what you suggested but that didn't seem to work. I'd be happy to provide you with any information you might need about my setup.
  • Options
    edited November 2007
    You have to do that for ALL the settings in conf/settings.php. The first error messages are related to a wrong $Configuration['LIBRARY_PATH'] value. it should be:$Configuration['LIBRARY_PATH'] = '/home/content/b/e/n/bengoheen/html/coltsalumni.org/forum/library/';(line 6 of conf/settings.php)
  • Options
    Almost there..... This is the error message I get now after changing all those settings: Error Message The connection to the database failed: Affected Elements MySQL.OpenConnection(); The error occurred on or near: Access denied for user 'b_goheen'@'linhostssl16.prod.mesa1.secureserver.net' (using password: YES) For additional support documentation, visit the Lussumo Documentation website at: lussumo.com/docs
  • Options
    edited November 2007
    Check conf/database.php and update the following the settings:
    $Configuration['DATABASE_HOST'] = 'linhostssl16.prod.mesa1.secureserver.net'; $Configuration['DATABASE_NAME'] = 'SomeDBname'; $Configuration['DATABASE_USER'] = 'b_goheen'; $Configuration['DATABASE_PASSWORD'] = 'xxxxxx';

    The address of the DB, the name of the DB, your db user name or your password might have changed.
  • Options
    The database host name was different then what you had specified. But I looked it up and changed it to what it should be and it works now! Thank you so much for the help!!!!! PS - You wouldn't happen to know about fixing my plogger error message, would you? http://www.coltsalumni.org/media/photos
  • Options
    No, but it's the same the problem, something wrong with your db settings.
  • Options
    nevermind, I got that working correctly now too. Thanks again!
  • Options
    Nice design by the way!
This discussion has been closed.