Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Making sticky without getting sticky

edited November 2007 in Vanilla 1.0 Help
Would it be possible to make a discussion sticky w/o having "[Sticky]" displayed next to the discussion title?


  • Options
    There are several discussions about these labels. One easy way would be to edit your language definitions.php file. In there, you have:
    $Context->Dictionary['TextWhispered'] = 'Private'; $Context->Dictionary['TextSticky'] = 'Sticky'; $Context->Dictionary['TextClosed'] = 'Closed'; $Context->Dictionary['TextHidden'] = 'Deleted'; $Context->Dictionary['TextSink'] = 'Sink'; $Context->Dictionary['TextBookmarked'] = 'Bookmarked'; $Context->Dictionary['TextPrefix'] = '['; $Context->Dictionary['TextSuffix'] = ']';
    You could just delete the word Sticky, but then you would still see the "[]". To remove these (for all labels, you would delete the [ and ]. You would then have:
    $Context->Dictionary['TextWhispered'] = 'Private'; $Context->Dictionary['TextSticky'] = ''; $Context->Dictionary['TextClosed'] = 'Closed'; $Context->Dictionary['TextHidden'] = 'Deleted'; $Context->Dictionary['TextSink'] = 'Sink'; $Context->Dictionary['TextBookmarked'] = 'Bookmarked'; $Context->Dictionary['TextPrefix'] = ''; $Context->Dictionary['TextSuffix'] = '';
    The other labels would now still show up but without the [ ].
  • Options
    well, I just tried that if you put at the end (before '?>') of conf/language.php this line

    $Context->Dictionary['TextSticky'] = '';

    it won't display [] for it, because it displays prefix and suffix only if it is not empty.

    the only thing is that this affect all Sticky discussions
  • Options
    Thanks jimw and klip! Here's what happened - Per jimw's suggestion, I simply removed the word "sticky" from: $Context->Dictionary['TextSticky'] = 'Sticky'; but I left the bracket lines $Context->Dictionary['TextPrefix'] = '['; $Context->Dictionary['TextSuffix'] = ']'; and for whatever reason neither the word "sticky" or the brackets appear. Maybe it's due to the style/theme I'm using(?) I don't know, but since it's doing EXACTLY what I wanted it to do, I'm just going to leave good enough alone. If i start farting with it I'll never get it back the way I originally wanted it!
  • Options
    as I said removing just TextSticky definition is enough since if the definition is empty it won't display TextPrefix and TextSuffix :) I guess putting this definition to conf/language.php is maybe more clean way because if you have more languages allowed this would work only with the translation you use (because other language definitions will be used) but also I may be wrong. I'm just too much messing around Vanilla localization these days.
  • Options
    My bad klip...I didn't read your post correctly. Either way, I got what I came for; THANKS!
This discussion has been closed.