Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Connection refused to... localhost?

edited August 2005 in Vanilla 1.0 Help
Alright, so, I just set up Vanilla. Nothing unusual in my environment, used the autoinstaller, bing bang boom, forum. Sweet, huh? Mostly. Until I tried to log in. What happened depended on which browser I was using. -- Using IE, after I put in my username and password and hit "Proceed," I get one of their delightfully unhelpful "friendly error" messages. Refreshing took me to the login success page. -- Using Firefox, after I put in my username and password and hit "Proceed," I almost immediately get an error dialog that says "Connection refused to 127.0.0.1." Clicking proceed again then takes me to the login success page. While this is just a minor thing, it's honestly very annoying, and I was wondering if anyone knew (a) what it was or (b) how to fix it. I haven't found anything pertaining to it either on here or on the wiki, so I'm turning to you all. :) Thanks!

Comments

  • Options

    Are you certain Apache webserver is running? What environment are you using? Was it an all in one installer or did you do individual installs of PHP / MySQL?

  • Options
    lechlech Chicagoland
    phil, is this a local installation or out on a real server over the internet? 127.0.0.1 is typically just a software loopback address, you shouldn't even be using it to make connections over a LAN. If you're behind a proper router setup, try an IP in the 192.168.(0-255).(0-255) region (or whatever ip you assigned to the computer running vanilla). If you're on just a simple network hub, this will make things more difficult as all computers connected to that hub receive and respond (typically) to any traffic on the setup. If it's a local address just try http://localhost instead which should clear things up depending on what local webserver you're running.
  • Options
    edited August 2005
    unfortunate: Yes, Apache is running fine. It's an OS X 10.4 machine, built-in install of PHP, individual install of MySQL. lech: it's a real server over the internet, not a local installation. It is running behind an actual router, and all web traffic is forwarded specifically to the webserver.
  • Options
    Nevermind. Found it. Putting it here for future generations. Apparently the stock version of Apache that comes with OS X 10.4 tiger does NOT have a server name set at all... not even the one that you can set for the machine in the Sharing preferences, the same pane that turns Apache on and off (?!). After adding one to Apache's configuration and restarting it, it works like a charm.
  • Options
    lechlech Chicagoland
    Ahh, there we go, ok, I was curious as to what might be causing this. Didn't know the server was running on OSX either so that wouldn't have been on my list of things to check. Nice fix phil.
  • Options
    edited August 2005
    I was about to suggest that phil. I also have a local verson running under tiger. I am glad you got it working now.
This discussion has been closed.