Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Default theme not loading

edited January 2008 in Vanilla 1.0 Help
I just installed a fresh copy of Vanilla to test out. FOr some reason though the links to the js/css files are not pointing to the right directory and I am viewing the forum naked. Any ideas? In the html output I see that the files are linked to as /style.css etc.. not the actual path

Comments

  • Options
    Hi, could you give us an URL?
    There's a $Configuration['DEFAULT_STYLE'] item in the conf/settings.php, what is it saying? And the Themes & Styles page?
  • Options
    I'm having the same problem. Surely just a configuration issue, but it isn't yet obvious where. I extracted Vanilla's zip file into /var/www/localhost/htdocs/ and renamed the directory beta instead of Vanilla-1.X.X. Adding my initial user works, and db access is setup correctly, etc.. The conf folder (and all sub files, folders) are set to very loose permissions of 777 for the time being. http://olpc.osuosl.org/beta <- the temporary location for the Vanilla install, while I test it out. Choice excerps from my default settings.php file: $Configuration['THEME_PATH'] = '/var/www/localhost/htdocs/beta/themes/'; $Configuration['DEFAULT_STYLE'] = '/themes/vanilla/styles/default/'; $Configuration['WEB_ROOT'] = '/beta/'; $Configuration['BASE_URL'] = 'http://olpc.osuosl.org/beta/'; I'm sure I'll smack my head when I figure out what I'm doing wrong. Cheers!
  • Options
    Theme works for me on that site...
  • Options
    same here
  • Options
    Ok, so I've fixed part of the problem. Because my install is not in the webroot ( http://olpc.osuosl.org/ ) but instead it is in /beta/, at least 1 of the config options was not looking through the correct path. For instance, I had to manually prepend /beta to the default style path. This setting adjust that path to the CSS files, so adding it made things fall into place nicely: $Configuration['DEFAULT_STYLE'] = '/beta/themes/vanilla/styles/default/'; Current problem, my admin account reverts to the old configuration settings. Is this cached somewhere? I've cleared cache and session data in firefox, cosed and reopened Firefox. Tested multiple times (guest user vs. admin account) and always the same result. If I'm logged in, theme paths break (it looks for /vanilla.css, if I view source on the root vanilla forum page), if I am a guest user it looks for the correct theme path (for me, /beta/themes/vanilla/styles/default/vanilla.css)... Completely different paths for the same file determined by my authentication level. Kind of confused why. Does this setting get put into the db under my user?
  • Options
    The theme path will be stored in the database too - check that out.
  • Options
    For those reading along at home: In the database table LUM_User, check the StyleID field. My (broken) admin account had this value set to one (due to some testing I did, probably when I tried to reinstall the default theme). I changed this value back to "0" (zero) and the theme loaded for me properly again. NOTE: Don't edit your database by hand if you don't feel like breaking things. This is a non-production forum, I'm just trying to get it up and running. Current problem: the lefthand menu links, drop-down box, etc. do not load. So, from the looks of it, there is no way to reach the Administrative settings page, add posts, etc. This still looks like a broken javascript/theme/style path issue, just not sure where or how to fix. Thoughts welcome!
  • Options
    Not to spam this thread, but I do want to document the problem in case other users think they are going crazy with this bug/issue. A clean, fresh install in the root directory of a new virtualhost (forum.laptop.org/*) exhibits the same behavior as previously mentioned. That is: the default account I created during setup has a StyleID (1) that does not exist. Checking the Style's table, the default style entry has a StyleID value of 4, of all things. Using phpmyadmin, I changed the initial user's styleID to match. This makes the Theme load, but no discussion or left menu navigation is visible. Manual db edits are clearly a sign that something is wrong. This was on an an empty database, following the exact steps of the setup guide. The same behavior has shown up on 3 clean installations (twice in a subdirectory of an old side. foo.com/beta/post.php, for instance) and now once in this new site, at the root (bar.com/post.php ...) Attempting to post a thread (by manually typing in the URL) gives a "you do not have permission to post" error, even though I am signed in as the should-be administrator. No email notifications are being sent out for new user requests. Is this a related issue, perhaps?
This discussion has been closed.