Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

LOGIN: A fatal, non-recoverable error has occurred

edited January 2008 in Vanilla 1.0 Help
I just did a fresh install and I can't log in as the administrator. Here's the error message: Error Message An error occurred while attempting to validate your credentials Affected Elements Authenticator.Authenticate(); The error occurred on or near: Illegal mix of collations (latin1_swedish_ci,IMPLICIT) and (utf8_general_ci,COERCIBLE) for operation '=' -------- I've looked up the log in issue as it relates to COOKIES-DOMAIN and attempted to change them. Here's my latest revision of the conf/settings.php file: <?php // Application Settings $Configuration['SETUP_TEST'] = '1'; $Configuration['APPLICATION_PATH'] = '/var/www/html/tvcforum/'; $Configuration['DATABASE_PATH'] = '/var/www/html/tvcforum/conf/database.php'; $Configuration['LIBRARY_PATH'] = '/var/www/html/tvcforum/library/'; $Configuration['EXTENSIONS_PATH'] = '/var/www/html/tvcforum/extensions/'; $Configuration['LANGUAGES_PATH'] = '/var/www/html/tvcforum/languages/'; $Configuration['THEME_PATH'] = '/var/www/html/tvcforum/themes/vanilla/'; $Configuration['DEFAULT_STYLE'] = '/tvcforum/themes/vanilla/styles/default/'; $Configuration['WEB_ROOT'] = '/tvcforum/'; $Configuration['BASE_URL'] = 'http://www.thevisualchurch.com/tvcforum/'; $Configuration['FORWARD_VALIDATED_USER_URL'] = 'http://www.thevisualchurch.com/tvcforum/'; $Configuration['SUPPORT_EMAIL'] = 'support@thevisualchurch.com'; $Configuration['SUPPORT_NAME'] = 'Brian Tetamore'; $Configuration['APPLICATION_TITLE'] = 'The Visual Church Forum'; $Configuration['BANNER_TITLE'] = 'The Visual Church Forum'; $Configuration['COOKIE_DOMAIN'] = '.thevisualchurch.com'; $Configuration['COOKIE_PATH'] = '/tvcforum/'; $Configuration['SETUP_COMPLETE'] = '1'; ?>

Comments

  • Options
    Well, after working on this all day and searching various post I found an answer from another post. For some reason the languages in my database were messed up. So I reset the database language to Thanks to the following post for the answer: Max_B Aug 21st 2006 block userblock comment# 2 When creating you database, before running the install script, you should declare the database as being of DEFAULT utf8 encoding. From hte message it looks yours is latin1. Also be sure to use latest SVN mods from Mark about "SET names utf8"
This discussion has been closed.