Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

MySQL Connection problems in previously-working installation

edited January 2008 in Vanilla 1.0 Help
All of a sudden I started receiving a fatal, un-recoverable error regarding the connection to the mysql server: "The error occurred on or near: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)" There are a number of issues here: 1) The conf file (included below) does not ask vanilla to connect via a local socket, but to a remote server and always has 2) I can connect to said remote server manually from the vanilla machine using the vanilla credentials 3) My other php/mysql sites (non-vanilla) on this machine are working fine I'm not sure what to try next? I would really appreciate a hand. ==BEGIN ./conf/database.php== // Database Configuration Settings $Configuration['DATABASE_HOST'] = 'sqlserver'; $Configuration['DATABASE_NAME'] = 'iago_vanilla'; $Configuration['DATABASE_USER'] = 'vanilla'; $Configuration['DATABASE_PASSWORD'] = 'xxxxx'; $Configuration['DATABASE_CHARACTER_ENCODING'] = 'utf8'; $DatabaseTables['User'] = 'LUM_User'; ... ... ==END ./conf/database.php==


  • How long has this issue been present? You might find that there are connection issues between your web server and your db server and this issue may disappear as suddenly as it came.
  • I has persisted now for 2 days. As I went back over my actions this week, I did do a relatively large upgrade of system software on the sql server, but Mysql was not touched and nothing was touched on the App server. And again, all the other php/mysql sites on the server are working fine. *keeps digging*
  • It's odd that mysql_connect would fail only in Vanilla and not anything else that uses it...
  • did you upgrade PHP somehow?
  • Not on the app server, no. *goes to double check the version status on said server*
  • Is there some sort of general Vanilla diagnostic I can run to get a wider picture?
  • Well, here's what worked. I still have no idea why it stopped. I have been managing my database configuration via conf/database.php. I was not aware of appg/database.php. When I found it I tried just pasting the $Configuration parameters for my database and it suddenly worked. I'm confused because the only other time I've had problems is when the conf/database.php got accidentally wiped. Are there really two database config files? In what order are they parsed? Perhaps I'm just completely mis-understanding what's actually going on.
  • I was under the impression that the files in appg/ were used a templates for the files in conf. So on a new Vanilla install it copies the files in appg to conf and then edits the conf ones without touching the appg ones.
This discussion has been closed.