Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Insane Error Possibly Causing Big Problems.... HELP!

edited January 2008 in Vanilla 1.0 Help
Hello, Long time Vanilla user... I run it for my company only forum at my office and from time to time I check out the add-ons to see if there are any new useful ones out there, and if so I'll test them and remove them if theyre no good.... So tonight I was adding a few new add-ons, one of which was Vanilla Voting 0.2 ( This required me to download 2 .php files to replace current ones after I installed the extension so I did (after backing up the original files) and alas I couldnt get the add-on to function properly so I went in and uninstalled it, restored the original .php files that had been replaces and then went into my FTP and deleted the VanillaVoting folder from the extensions. So I move onto the next add-on I'm testing and when I go in to check it off, this error pops up.... So I click ok, hoping to move on, but what I notice is that the extension I'm trying to enable isn't finishing it's "enabling waiting animation" thing... like, where the check box is its doing that loading swirling thing... after a few minutes I was like, enough of that and I hit refresh... the page loaded and the extension was enabled... I went on to test enabling and disabling new and old addon's to see if this error would happen more and it happened everytime I checked or unchecked any check box in the extensions list... I just hit refresh and it's fine, but one thing I noticed shortly after is that my Inline Images add-on has stopped working since then... well, it didnt stop, but all the images we had uploaded before, and any images we upload now, just show up as the red X... I tried disabling Inline Images and reinabling it... no luck, so I uninstalled it completely, re-added it and still no luck... so I download Vanilla Voting again and set it all up hoping to just leave it there disabled and all would be fine.. but I'm still getting that error whenever I click a check box, and my Inline Images still aren't working! Sorry for the long post but I wanted to be as specific as possible in hopes that someone can help me.... please help! Thank so much, Nick


  • Options
    That is really odd that those lines would be appearing in a message box like that. Looking at voting, it looks like it adds some configuration lines to the conf/database.php file. The very same lines that are appearing in that message. Take a peek in there and remove all the code that you see in that message. (of course, make a back up first!)
  • Options
    Interesting.... thank you, I'm going to try that right now and see what happens.... anyone else?
  • Options
    Brilliant... not only did it solve the error popping up but it fixed my image issue as well! Thank you so much!
This discussion has been closed.