Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Attachments and Inline Images not working

edited June 2008 in Vanilla 1.0 Help
Did someone get a fix to the inline images not working? All I get is a link with the filename in the post, if I click the link it trys to open it with Thickbox, if I copy the link and place it in a new browser window a download prompt opens up so it links to the file just fine it just doesnt display.


  • No. You can read a lot of threads regarding this, but nowhere is a possible fix. To me it seems, there is a working fix somewhere, but we both don't know how to find it. It seems this is getting a littlebit chaotic here...'chaotic good', at least. But chaotic.
  • Fixed. In my case, it was a wrong coded language-file as explained here:
  • edited May 2008
    Sorry Cassini, but I don't understand the method explained in this post; can you explain please ?
    I tried to save the definitions.php (for french) with Unix CR and Western Iso Latin1 encoding, but it's worst : no images, and every accented character is replaced by "?"
  • edited May 2008
    bwaje, I just changed the encoding from ANSI to UTF-8. That was it. After reviewing my both language files (english and german) I found, that one of them is written in DOS-format (the english one, CR+LF) and the other one is an UNIX-file (LF). Both are encoded in UTF-8 (now). The german file was encoded in ANSI and *this* messed up the inline images. So it seems that CR+LF is not the real problem. Encoding is. Use UTF-8 instead.
  • It worked.( changing the file encoding of default.php ) wow. thanks
  • Hi, When I'm signed out and viewing someones profile I get the following at the top of the page: Notice: Trying to get property of non-object in /home/.pilar/vbunet/ on line 59 Notice: Trying to get property of non-object in /home/.pilar/vbunet/ on line 60 But when I'm logged in the errors vanish. Do you know how I can get rid of these errors?
This discussion has been closed.