Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

transfered hosting from Godaddy to AN Hosting - mysql databases messed up again

edited February 2008 in Vanilla 1.0 Help
Let me start out by saying thank you everyone who can help me with this. I had hosting through Godaddy and am in the process of transferring over to AN Hosting. The mySQL databases have also been transfered from Godaddy and dumped (whatever that means). The site I'm using is an add-on domain and I don't know where the new databases are located at. I'm getting a ton of error messages so obviously there's some problem, just don't know exactly what do to fix it. I have posted before when I did some changes at Godaddy before, so I have some experience with this in general. Here is the prior discussion: My site is located at Please somebody help me! Thanks again.


  • Options
    edited February 2008
    In your conf/settings.php file, check your $Configuration['APPLICATION_PATH'] item, and maybe some others.
    The error message gives you the right path to set:
    instead of
  • Options
    I made the suggested changes and it still isn't working. Godaddy's mySQL databases had names like '' where I believe AN Hosting uses 'localhost'. So now this is the error message I'm getting: A fatal, non-recoverable error has occurred Technical information (for support personel): Error Message The connection to the database failed: Affected Elements MySQL.OpenConnection(); The error occurred on or near: mysql_connect() [function.mysql-connect]: Can't connect to MySQL server on '' (4) For additional support documentation, visit the Lussumo Documentation website at:
  • Options
    You should also edit conf/database.php to reflect the hosting changes (host database user and password).
    I'm pretty sure such answer is already there at a search cost…
  • Options
    I've tried to edit the database.php file and that didn't seem to work. I called tech support at AN Hosting and they informed me that the path is actually: /home/movegoh1/var/lib/mysql Do they know what they're talking about because I seem to get a lot more error messages when I change the path to that. Now I've switched back to: /home/movegoh1/public_html/website-coltsalumni/ and have the database settings to the following: $Configuration['DATABASE_HOST'] = 'localhost'; $Configuration['DATABASE_NAME'] = '_bgoheen'; $Configuration['DATABASE_USER'] = 'movegoh1';
  • Options
    Are you guys done helping me now?
  • Options
    Man, just check out your settings!
    If you'd have set database host to 'localhost', the error message wouldn't read 'Can't connect to MySQL server on '' ' !
    The settings must be put in conf/database.php (not in appg/database.php)
This discussion has been closed.