Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Using Vanilla on non-English language

edited February 2008 in Vanilla 1.0 Help
Well, I got the latest Vanilla release installed everything and added addons and it's sweet. Yet, I got on problem. When I tried posting some comments in Greek (which will be the language used in it) the characters appear as question marks. I tried changing encoding on the browser and where I found relevant settings in the configuration files, but no luck.

It seems as if they get converted to question marks upon posting a comment and I got no clue as to why.

I would appreciate some help here.

PS.: I will be using the default English interface, this has to do with discussions only.

EDIT: I found out by messing with mySQL (I had a hunch) that vanilla's tables get a latin1_swedish_ci encoding. On the other side, phpbb uses utf8_bin and joomla uses utf8_general_ci. Changing the encoding of the Body field in the LUM_Comment table to the latter encoding and reposting the comment worked. Any ideas why it would be so? I guess it would be fine if I changed the encoding of the whole db?


  • Options
    There is some pretty wholesome documentation about character encoding in the wiki. that should answer any questions you have.
  • Options
    Just read that. Pretty much what I did to fix it. Though I didn't know about the configuration setting.

    You can also just export the existing database, delete those default charset fields and re-import it with phpMyAdmin (instead of creating a whole new table).

    Thanks again :)
This discussion has been closed.