HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

Looking for a file that does not exist

edited April 2008 in Vanilla 1.0 Help
When I logged into to my forum this morning it was redirecting me to a page for a upgrade installation. I have been running 0.9x so I downloaded the latest version after backing everything up. I removed all my filed I had previously and uploaded the new content like it says to do here http://lussumo.com/docs/doku.php?id=vanilla:upgrading at the very bottom I click on the "Click here to upgrade from Vanilla 0.9.2.x to Vanilla 1.1.4" link and it brings me to a /setup/setup/index.html file that doesn't exist!? Can someone help please?

Comments

  • it should link to /setup/upgrader.php try typing that in manually, but i'd be a bit weary considering the flaw; if i were you I would redownload the files, then try the manually going to /setup/upgrader.php
  • Yeah ... I tried going to the setup/upgrader.php manually but for some reason it redirects me to that setup/setup/index.html file?!
  • try downloading and re-uploading vanilla
  • Ok ... I tried it again and I still get the same error. I removed EVERYTHING, started blank and it still doesn't work. See for yourself http://arso.qc.ca/forum/setup/index.php and click on the link at the bottom - upgrade.
  • is it in the same directory as the old vanilla? if I click on the "Click here to install a completely brand new version of Vanilla", it says that it doesn't have write permisions to /conf/ that may be an issue?
  • edited March 2008
    Yes it's in the same directory as the old one but i completely emptied it before uploading the new version. I changed the permissions to 777 on that conf directory. I tried the update again and it didn't work. What happens if I do the Install instead of the Upgrade? I don't want to loose all the previous forum data (posts, users) from the previous version!? Thanks!
  • using install will not let you use anything but a blank database.
  • So ... what do I do then?! This is not working and I need to get this back up ASAP for my client!
  • Is there anybody else that can help me? As much as I love supporting this forum software, if I can't get any help, I'm going to have to switch software which I would rather not do.
  • You could try upgrading to say v1 and then upgrading to v1.1.4
  • Where can I get old version of Vanilla?
  • edited March 2008
    lussumo.com/downloads/Vanilla-ver#.zip

    example:
    http://lussumo.com/downloads/Vanilla-1.1.4.zip http://lussumo.com/downloads/Vanilla-1.1.3.zip http://lussumo.com/downloads/Vanilla-1.1.2.zip http://lussumo.com/downloads/Vanilla-1.1.1.zip http://lussumo.com/downloads/Vanilla-1.1.zip
    and I think that's as far back as they go, but experiment a little bit.

    EDIT: they go a lot father back than that

    type in lussumo.com/downloads and you'll get an index of downloads. They go back to v 0.9.0
  • Thanks guys! I'll try that and let you know!
  • I know it's been almost a month but I just wanted to let you know that I got it working by upgrading from 0.9 to 1.1 and then 1.1.2, etc... Thanks for the help!
This discussion has been closed.