Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

unable to start a discussion

edited February 2008 in Vanilla 1.0 Help
I just created a brand new forum and uploaded a new copy of vanilla 1.1.4 and for some reason when I try to start a discussion, it gives me a blank page. I have administrator role. the url shows as: http://www.mosaic.org/forge/forge_forum/post.php
Did I miss a step?

Comments

  • Somthing might have been lost in the upload, so try uploading post.php and the /js/ and /library/ folders just to be sure. If that doesn't work, try posting a message with the default Vanilla theme and see if that works.

    Come back and let us know what happens and we'll work on it from there.
  • Thanks so much for your willingness to assist me. Currently I have 3 forums and they are all having the same problem. I went ahead and uploaded all of the files you suggested, but it didn't work; then changed the theme back to default vanilla and it still didn't work. Any other suggestions before I get mobbed by 3 angry group members?
  • Whats really interesting here is that the appropriate HTTP headers are coming through, yet there is nothing in the page body.

    Are all three sites on the same server? Maybe something like mod_security is blocking the page name, so lets try copying post.php to another file named something like vanilla.php and try navigating to forge_forum/vanilla.php

    If that doesn't work, then see if you can find a apache or HTTP error log and see if anything in there mentions post.php.
  • Yes, all three forums are on the same server under different sites. How do I copy post.php to another file? Is it the same as renaming it: vanilla.php? I renamed it and still didn't work. ;-(
  • edited February 2008
    Yah, renaming would have been good enough.

    Any luck with the error log? If not, we can try turning them on manually by editing conf/settings.php and adding two new lines of code:ini_set("display_errors","on"); error_reporting(2047);
  • I was not able to get any info from the error log and haven't attempted to turning it manually yet. What I did was contact the tech support from the server company and related all the information we had attempted so far in hopes that it is something like a mod_security block. As soon as I hear from them, I will report back here, but I'm really hoping its something that they did from their end of things.
This discussion has been closed.