Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Register-Button missing and other IE-Displaying bugs

edited March 2008 in Vanilla 1.0 Help
I've got one very serious and two minor displaying problems when using the latest IE. The serious problem is quite funny, because it prevents users using Internet Explorer from registering to the board, simply because they can't click the register-button in the login menu. It's simply not shown. I've had a look at the people.css but can't find a solution to this problem. Maybe trying to inline the UL-Tags. But my css-abilities can't figure out where to place this.

Here's a scaled-down screenshot:

The two minor problems occur when using the announcement and/or guestsense addons. They seem to stretch the context a fair bit and destroy the whole page. Same here, only visible for IE-Users.

Another Screenshot:

I'm using the default vanilla theme and have done some small changes to the heading. Nothing else has been edited.

So, what can I do? You can test yourself using this link.


  • Options
    One possible big issue is there are junk characters being sent to the browser before anything else--this is usually caused by a language file or extension that has the characters outside the <?php ?> tags: 810(CR)(LF) (EF,BB,BF,EF,BB,BF,EF,BB,BF,EF,BB,BF)<!DOCTYPE·html·PUBLIC·"-//W3C//DTD·XHTML·1.0·Strict//EN"·"">(LF) <html·xmlns=""·xml:lang="de-de">(LF) (HT)<head>(LF)

    The EF, BB BF appears to be a byte-order mark but I think there should only be one. The extras could have been inserted by your text editor when you changed some files.

    After removing those characters, if the problem is still around, your best bet would be to remove the customizations, one at a time until you see the problem go away.
  • Options
    edited March 2008
    Ok, I've figured out what caused the Regestration-Button to miss. It was the German language pack. Switching to English and deactivating the two extensions solved it of course and it even works with my changes to the theme. Hurray!

    As soon as I switch to German, the Button goes missing. As soon as I turn on the announcment or guestsense addon, I get the stretching problem. Thing is, I didn't change anything in the German language pack. I even tried downloading it and unzipping it directly onto my webserver. This did not solve the problem.

    I remembered making some changes to the announcement (including boarders on the left and right and adding a padding left and right of 10px) and guestsense addon (translated the appearing text to german), so I reinstalled them, which solved the problems. As soon as I open and save any of the files (even without making changes), I get the problems again. I tried using the MS Editor and specifically saving to UTF-8, but this didn't help.

    So any ideas on how I can edit the files without adding any byte-order mark? And how do I get the button appearing with German?

    Solved! I downloaded a hex editor to have a look at the files. In fact, MS Editor and MS Wordpad, which i was using until now, are adding byte-order marks to beginning of the files. The German dictionary.php has one to many too. Perhaps, this wants to be changed.
This discussion has been closed.